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OPEN MIND tool database1 Database Formats 
OPEN MIND tool database
Introduction

Please note that the demo data in the tool database is provided for illustration, and not nec-                
essarily for production purposes. OPEN MIND disclaims any liability for damages resulting           
from the use of demo data in a production environment.

Database Formats
As the MS Access (.mdb) format does not support 64-bit technology, it has been changed to               
SQLite (.db) with Version 2011. Please note that SQLite tool databases cannot be protected             
by passwords at this time.
SQLite tool databases cannot be accessed by several users at the same time. This is only               
possible using SQL Server technology, which is supported as of Version 2014.1. 

If you are using SQL Server databases, ensure that you are also using an up 
to date driver. The name of the driver must read: 
SQL Server Native Client 10 or SQL Server Native Client 11. 
Do not use drivers with the name SQL Server, even if these appear to be 
newer. This driver cannot transfer more than 400 kB of data to the server. As 
a result, you cannot use it to store 3D tools in your database. 

Converting the tool database to the new database system
In order to use databases created under Version 2010 and older, you must convert them to               
the current format.

1. First, start your 2010 tool database from the Start menu under Start > Programs > 
OPEN MIND > 2010 > Tool Database.

2. Open the database which you want to convert to the new format, select it in the browser 
and select the Export > *.xml function from the shortcut menu (right mouse button). 
Your old database will be saved in a neutral tool exchange format which can then be 
imported using the tool database.

3. Next, start your current tool database from the Start menu under Start > Programs > 
OPEN MIND > [Version number] > Tool Database.

4. Create a new (empty) database (File > New) and select under File type the format 
Sqlite database (.db).

5. In the browser, select the newly created database and then right-click the Import func-
tion in the shortcut menu. 

6. Then select the previously created file in the .xml format that you wish to convert to the 
new format.

The Import status dialogue informs you about the current status of the data import. 
Invalid lengths or duplicate designations are indicated in the Constraint Violation dialogue           
and must be edited. Constraint violations can be resolved by different methods:

Automatic: All conflicts occurring during the import will be resolved automatically, so that all             
elements can be imported from the old to the new database.
Ignore: Should only be used by experienced experts.

The import continues even if there is no conflict solution. Since the application 
of this option may result in faulty tools, it is only available if the options Leave, 
Overwrite and OK are disabled. 

The Leave/Leave All: The current element/all elements of the old database is/are preserved.
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Overwrite/Overwrite All: The current element/all elements of the old database is/are overwrit-           
ten with the new element(s).
Deviation: The difference between the element of the old database and the element to be              
imported is shown.

Database files in the *.mdb format will not be deleted after import to the current 
database format, but saved to your system in the same location under the 
name [Database_saved.mdb].

During the import, the tool heads defined in older versions are converted to tool spindles.              
Consequently, all references are retained. However, the converted tool spindles are no           
longer displayed in the OPEN MIND tool database. You can nevertheless use them when             
assembling a tool in hyperMILL. 

A database conversion is performed when importing tool data from an older 
version into the current format. This operation should not be stopped, as other-
wise hyperMILL will not be able to load any data and joblists and jobs will no 
longer be available. 

Starting the OPEN MIND tool database
Start as a separate application:

Via the Windows Start menu: All programs > OPEN MIND > hyperMILL > 
[Version] > Tool database [Version]

Start from hyperMILL:

Click the icon in the hyperMILL browser, Jobs tab.

User interface
The user interface consists of the following elements:
(1) Menu bar, (2) Toolbar, (3) Browser, (4) Data view of the overview window, (5) Graphics               
area, (6) Status bar.
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The menu bar

File New...: Create a new database. 
Open...: Open an existing database. 

Edit Cut, Copy and Paste:  
Standard Windows functions that are valid for all entries in the data-
base browser. 

View Show or hide the toolbar, status bar, browser window. 

Options Accuracy: Measurement system configuration. 

Help Tool Database Help: Start. 
Info...: Display version number and other version details. 
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The toolbar

Save or Delete a data record.

Metric Switch measurement system (metric/inch).

Start the online help. 

Geometry preview
1. Switches between 2D and 3D representation. 
2. Switches between parametric and free tool geometry. 
3. Show dimension.

Create a new database or open an existing database.

The browser
In the browser, all elements of the database are created and displayed. You can use the               
dropdown combo box to change the structure of the browser display.
For information on the entry selected in the browser window, refer to the data view of the                
overview window and the graphical preview.
The display structure for the data view of the overview window (detailed view / list view)               
depends on the entry selected in the browser. 
If you have selected a folder, the elements of this folder are displayed in a list view within the                  
data view.

You can define the parameters displayed in the list view by right-clicking in the upper area of                
the data view and activating the required parameters.

Tool name
Tool name

Tool length

Rad. D 5.0 HSS
Rad. D 4.0 HSS

Rad. D 3.0 HSS

Tool length

Tool diameter
Tip length

If you have selected one element within a folder, this element is displayed in a detailed view                
within the data view.

Create database
To create a new database:

1. Select File > New on the menu bar and specify a name.

2. Now click Create to create the database.

You can use a password to protect all database entries. Information in section 
Changing the password.

 The newly created database appears as an entry in the database browser.
To close the database, right-click the database entry and select Close.
To clearly group your tools (and other database elements such as holders or extensions),             
you can create new folders in the database browser. If the folder names begin with a combi-                
nation of numbers (such as 001, 002 and so on), the folders are listed in the browser in                 
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numerical order. We also recommend using two or three (maximum) hierarchy levels for the             
folder structure of your database.

Creating a folder 
To create a new folder in the browser window:

1. Select the Folder entry from the combo box for the browser window. 

2. Right-click the database entry and select New > Folder.

3. Specify a name and, if necessary, enter a comment. Comments appear as a tooltip.

Defining a tool
After you have created a new database and the necessary folders, you can begin to define a                
new tool. 

1. Switch to the Tools tab, right-click the previously created database entry and select 
New.

2. Select the required tool type from the list.

3. Specify a unique name for the tool type in the data view. A comment can later make it 
easier for you to select the correct tool. Enter any other required parameters.

If you define a non-permitted value for a parameter, the corresponding line in 
the data view is marked in red.

The newly created tool appears as an entry in the database browser. Geometry and technol-              
ogy data is displayed in the data view of the overview window. You can also save a tool as a                   
default. All the geometry and technology parameters are saved and used if you define this              
tool type again.
To save a tool as default, select the tool in the database browser and select Save As Default                 
in the shortcut menu.
The following sections list all tool types available in the tool database.

The chamfered profile cutter and countersink tool types are not currently sup-
ported by the hyperMILL cycles.
The Reamer tool type has been supported since Version 2014.1.
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Milling Tool
Generally applicable (A) and type-specific geometry parameters.

Lengths (1) Tool reach, (2) Tip length, (3) Tool length, (4) Gage length, (5) Chamfer length, (6) Cutting length, (7) Disc 
height, (8) Barrel height, (9) Lower chamfer height, (10) Upper chamfer height,

Diameters (11) Diameter, (12) Shank diameter, (13) Collar diameter, (14) Tip diameter, (15) Nominal diameter, (16) Base 
diameter

Radii (17) Corner radius, (18) Lens radius, (19) Barrel radius, (20) Base corner radius
Angles (21) Chamfer angle, (22) Lower chamfer angle, (23) Upper chamfer angle, (24) Barrel taper angle

Ball endmill (B), Endmill (C), Bullnose endmill (D), Lollipop, Touch probe tool (E), Woodruff             
(F):

For the ball mill, the radius of the cutting edge always corresponds to half of the tool diame-                 
ter.
Chamfer cutter (G), Chamfered profile cutter (H), T-slot cutter (J), Lens cutter (K):
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General barrel tool (L), Conical barrel tool (M) and Tangent barrel tool (N) ball (I) and sharp                
(III) variant, with corner fillets (II).
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Drilling tools
The following drilling tools are available in the tool database:
(11) Drilling tool, (12) Tap drill, (13) Boring bar, (14) Thread mill, (15) Countersink, (16)              
Reamer.

Geometry parameter tool type: Drilling tool (A), Tap drill (B)
(1) NC tool length, (2) Tool length, (3) Tool reach, (4) Tip length, (5) Chamfer length, (6)                
Shank diameter, (7) Diameter.
Drilling tool (A): (8) Tip angle.
Tap drill (B): (8) Pitch (p), (9) Lead in length, (10) Lead in diameter, (11) Back angle.

Tool type: Boring bar (C)
(1) NC tool length, (2) Tool length, (3) Tool reach, (4) Tip length, (5) Chamfer length, (6)                
Shank diameter, (7) Diameter, (8) Minimal diameter, (9) Maximal diameter.
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Turning Tool
The following turning tools are available in the tool database:
(1) Turning tool, (2) Recessing tool, (3) Axial recessing tool, (4) Parting tool, (5) Threading              
tool, (6) Roll turn tool.

General geometry parameters 
(1) Shank geometry, (2) Extruded geometry, (3) Extrusion thickness, (4) Axis distance, (5)            
Shank distance, (6) Approach angle, (7) Setting length X (8) Setting length Z (9) Mounting              
direction left, (10) Right, (11) Top, (12) Inverse, (13) Angle, (14) Mounting direction angle.
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The Axis distance (4) and Shank distance (5) geometry parameters in the 
graphical preview are with reference to the insert lying flat in the Z-X plane and 
not to the actual tilted view. 
Toolpath calculations are also with reference to a cutting point, which is calcu-
lated in this view.

Geometry data: recessing tool, axial recessing tool, parting tool
(1) shank geometry, (2) extruded geometry, (3) maximal radial depth, (4) maximum axial            
depth, (5) maximum cutting depth. 

The largest radial / axial depth and the maximum depth of cut relate to the groove or recess                 
to be machined. The value may be greater than the length of the insert.
Geometry parameters threading tool
(1) reversed not activated, (2) reversed activated
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Grinding bit
(1) NC tool length, (2) Tool length, (3) Tool reach, (4) Tip length, (5) Grinding height, (6) Cut-                 
ting length, (7) Chamfer length, (8) Cone angle, (9) Chamfer angle, (10) Shank diameter,             
(11) Collar diameter, (12) Diameter, (13) Lower cutting edge: (A) Chamfer, (B) Radius, (C)             
Sharp, (14) Radius, (15) Lower chamfer mode: (A) Angle and height, (B) Width and height,              
(16) Angle, (17) Height, (18) Width, (19) Height.
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Defining tool geometry

General
Define name, comment (optional) and measurement system. 

Geometry
Define the Diameter and Length of the tool.

Shank
Shank mode: Select either the Free or Parametric option to define the shank. Select None if               
a shank is not necessary.
In the Free shank mode, use the geometry editor to define the shape of the tool shank. See                 
chap. The geometry editor for information on the geometry editor. 

Open the geometry editor in the Free shank mode. Information in section 
The geometry editor. 

Delete freely defined geometry.

In the Parametric shank mode, specify the shank diameter and the method of chamfer defini-              
tion. With the Absolute (A) chamfer definition, specify a point for the chamfer end position (1)               
as an absolute value. With the Length (B) chamfer definition, specify the chamfer length (1)              
and with the Angle (C) chamfer definition, specify the chamfer angle (1). 
(2) Shank diameter, (3) Tip length, (4) Shank length, (5) Tool length.

Tip
Define the parameters for the tip of the tool. Information in chap. Milling Tool and chap. Drill-                
ing tools. 
To define a conical tool, enable the Conical tip option and define the Cone angle.

Free tip geometry: Open the geometry editor and define the tip geometry. 
In the Cutting area column, enable line segments that define the cutting 
part of the tool tip. 
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The non-cutting part of the geometry is used in the simulation to perform colli-
sion checks. 

The length of the tool tip is calculated automatically if the following conditions 
are fulfilled: The Conical tip parameter is enabled, the shank mode is set to Par-
ametric, Length is defined as the chamfer definition and the Chamfer length is 
0. 

The length of the tool tip is calculated automatically if the following conditions are fulfilled:
• The Conical tip parameter is enabled, 
• the shank mode is set to Parametric, 
• length is defined as the chamfer definition and 
• the Chamfer length is 0. 
The shank diameter is calculated automatically if the following conditions are fulfilled: 
• The Conical tip parameter is enabled, 
• the shank mode is set to Parametric, 
• a free tip geometry is defined, 
• the Chamfer length is 0. 
The following applies to the shank definition: Length of the chamfer >= 0 and length of the                
chamfer <= shank length.

Defining a tapered tool with a shank 
1. Select the required tool type on the Tools tab.

2. Specify the Shank mode on the Geometry tab in the data view in the Tool area and 
define the values for the diameter and length of the tool 

3. Enable the Conical tip parameter in the Tip area and define the Cone angle.

4. Specify the required parameters in the Shaft area
Insert Parameters
It is possible to define the two Core diameter (1) and Core height (2) parameters for tools                
with inserts. 

Top coupling
Define as standard for all tools. The top coupling connects the tool with another component              
(holder, extension) and is used when assembling an NC tool. Define the Minimal length and              
the Maximal length.

Defining a turning tool
1. On the Tools tab, right-click the corresponding database entry and select New > [Tool 

type].

2. Select or redefine the Insert and Tool Holder components.
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The Tool holder and Insert components are necessary to define a turning tool.

A Tool holder is made up of the Shank geometry (Part 1 and 2) and the Extruded geometry.                 
It contains all placement information to support inserts. 
By defining the Insert support you also set the Insert type to be supported by the tool holder,                 
and via the Clamping method, the manner in which an insert is to be mounted on the tool                 
holder.
The Insert component is also characterised by geometric parameters as well as a Mounting             
type. In addition, it is possible to assign to an insert the technology parameters Material, Cut-               
ter material and Purpose.

Defining an insert
Select a shape of insert in the Insert tab via the New > [Shape of insert] shortcut menu. 
Shape of insert:
(1) Rhombic, (2) Triangular, (3) Round, (4) W-shape, (5) Thread, (6) Simple thread, (7) Rec-              
tangle, (8) Parting, (9) Free form (10) X Full Roll Turn, (11) X Short Roll Turn, (13) T Full Roll                   
Turn, (14) T Short Roll Turn.

Alternatively, open the Edit ISO/ANSI code... dialogue via the From ISO/ANSI Code... short-            
cut menu. Each digit of the eight-digit ISO code stands for a parameter that can be defined                
using a selection field. information on the definition of the inserts according to the ISO/ANSI              
standard can be found in the following example.

Code C N M G 12 04 08 EL-
Digit 1 2 3 4 5 6 7 8

Numbers 1 to 8 of the ISO/ANSI code:
(1) Shape

(2) Free angle
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(3) Tolerance 

(4) Type of insert 

(5) Length

(6) Thickness

(7) Corner radius

(8) = Forming of the cutting edge and chip former designation: 
(F) Sharp, (E) Rounded, (T) Chamfered (negative chamfer), (S) Chamfered and rounded, 
(R) Right model, (L) Left model.
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Permitted combinations of tools and inserts:
Turning tool: Rhombic, triangular, round and W-shape insert
Recessing tool: Round, rectangular and free form insert
Axial recessing tool: Round, rectangular and free form insert
Threading tool: Threading insert

Specify a name, comment, measurement system and type of insert.
For free form inserts, the Insert type is not set, because this insert cannot be assigned to any                 
specific Clamping method (on the part of the tool holder).
Insert types: A- Through hole - No chip breaker, B - Hole chamfered at one side - No chip                  
breaker, C - Hole chamfered at both sides - No chip breaker, F - No hole - No chip breaker,                   
G - Through hole - Chip breaker at both sides, H - Hole chamfered at one side - Chip breaker                   
at one side, H - Hole chamfered at one side - Chip breaker at one side, J - Hole chamfered at                    
both sides - Chip breaker at both sides, M - Through hole - Chip breaker at one side, N - No                    
hole - No chip breaker, P - Through hole - No chip breaker, Q - Hole chamfered at both sides                   
- No chip breaker, R - No hole - Chip breaker at one side, T - Hole chamfered at one side -                     
Chip breaker at one side, U - Hole chamfered at both sides - Chip breaker at both sides, W -                   
Hole chamfered at one side - No chip breaker, X - Special shape

Available clamping methods (tool holder): C - Top clamping, D - Rigid clamp, M - Top and                
hole clamping, P - Hole clamping, S - With screw through hole.

Permitted combinations of insert type and clamping method (tool holder) are 
shown on the following table.
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 Insert type (insert)

A C F G H J M N P Q R T U W

Clamping method 
(tool holder)

C X X X X X X X X X X X X X X

D X X X X X X X X X X X

M X X X X X X X X X X X

P X X X X X X X X X X X

S X X X X X X X

To define the insert, specify the required parameters in the Geometry area. To change the              
geometry of an insert that was defined with an ISO/ANSI code, remove the checkbox at ISO/               
ANSI code active. 

 Click the icon to change the ISO/ANSI code.

Insert geometry parameters

Lengths (1) Length, (2) Thickness, (3) Height, (4) Cutting width, (5) Cutting height, (20) Width
Radii (6) Corner radius, (17) Radius
Angles (7) Angle, (8) front angle
Offset (9) Tip X offset, (10) Tip Z offset (11) Reference offset X, (12) Reference offset Z,
Other (13) Reference point, (14) Mounting point, (15) Cutting area, (16) Inscribed circle diameter, (18) Centre dis-

tance Z, (19) Centre distance X, (21) Mounting point, (22) Primary centre, (23) Secondary centre

(A) Rhombic insert, (B) triangular insert, (C) round insert.

(D) W-Shape insert, (E) threading insert, (F) simple thread insert.
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(G) Rectangular, (H) parting insert, (I) free form insert.

(J) X Full Roll Turn, (K) X Short Roll Turn.

(L) T Full Roll Turn, (M) T Short Roll Turn.
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Defining the geometry of the free form insert
The geometry of the Free form insert is defined together with the tool definition in hyperMILL               
by means of contour and point selection in the CAD system. 

1. On the Geometry tab in the tool definition, click Insert in the Tool area and select Free 
form insert.

2. Click Geometry and then click icon 1 to start contour selection in the CAD system. 

3. Select contour, Cutting area, Mounting point and Mounting direction point. 

Geometry

Reference offset x

Reference offset z

Thickness

Geometry

You can also use the Geometry editor from the tool database to define the geometry of the                
Free form insert. The geometry of the Free form insert must be defined as a closed contour.                
See chap. The geometry editor for information on the geometry editor. 
In the Cutting area column of the Geometry editor, select the contour elements that repre-              
sent the Cutting area of the free form insert and confirm your definition with OK.
The Cutting area must match the contour that is to be processed.
Reference point and Cutting area are displayed in the Preview window. The exact position of              
the Reference point results from the Reference offsets X and Z.

Inserts technology parameters
The Feedrate unit parameter (mm/min or mm/rev) is used to simultaneously switch the val-             
ues for the Feedrate XY, Reduced feedrate and Feedrate retract parameters. These param-            
eters are also displayed in the NC tool cutting profile, but cannot be edited there. 

Defining a tool holder
1. On the Tool holder tab, select the New tool holder function from the shortcut menu.
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2. Under Type, select Internal for turning tools for inside machining, or External for turning 
tools for outside machining. If the later application of the tool holder has not yet been 
determined, select the Unknown option.

3. Specify a Name and optionally a Comment for the tool holder.

4. Define the Measurement system (metric / inch).

5. If the tool holder should be defined using an ISO/ANSI code, enable the ISO/ANSI code 
active checkbox. 

6.  Open the Edit ISO/ANSI code dialogue by clicking the icon.
Each digit of the ISO/ANSI code stands for a parameter that can be defined using a selection                
field. Depending on whether a tool holder is defined for inside or outside machining (internal/              
external), different parameters will be available for the ISO/ANSI code. Possible ISO/ANSI           
parameters are:
(1) Type: Internal: Turning tool for inside machining, External: Turning tool for outside            
machining
(2) Boring bar type
(3) Shank diameter, (4) Length, (5) Insert length

(5) Clamping method

(6) Shape of insert

(7) Style, Type: external
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(7) Style, Type: internal

(8) Free angle

(9) Mounting direction (left, right, neutral)

(9) Shank height, (10) Shank width
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Define all further necessary parameters in the Insert support, Geometry and, if necessary,            
Advanced tool definition areas.

Defining an insert support
1. Define which insert the tool holder is to support. For information on the available inserts, 

see chap. Defining an insert.

2. The following options to define the Insert support are available:
• Use the selection field (1) to select the shape of the insert and define the geometric 

parameters or
• select an existing insert directly by clicking the icon (2) or click the icon (3) to define an 

ISO/ANSI code using the Edit ISO/ANSI code dialogue.

General

Insert 01Name

Comment

Measurement System

Insert support

Metric

Rhombic insert

If you define the insert support by means of the ISO/ANSI code, the geometry parameters              
are initially firmly linked to the ISO/ANSI code and cannot be edited. To edit the geometry               
parameters, click the icon (4) to break the link between the geometry parameters and ISO              
code.
To mount an insert to the tool holder, you must use an appropriate clamping method. Infor-               
mation on possible combinations of clamping methods and insert types can be found in             
chap. Defining an insert.

Defining a tool holder geometry
The following options are available to define the tool holder geometry:
• Import the geometry as a 3D model using the hyperMILL TOOL Builder
• In the tool database with the geometry editor 
• In hyperMILL / in the CAD system 

Importing as a 3D model
Import a tool holder from a 3D model (format: *.stl) using the hyperMILL TOOL Builder. To do                
so: 

1. Enable the 3D data option.
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2.  Start the hyperMILL TOOL Builder. For more information, see the hyperMILL 
TOOL Builder product documentation.

 For 3D geometries of tool holders, it is no longer possible to edit the profile in the                 
Geometry editor. For information on the hyperMILL TOOL Builder, see the hyperMILL TOOL            
Builder product documentation.

In the tool database with the geometry editor
To define the geometry in the tool database, click the icon (1) to open the Geometry editor.                
See chap. The geometry editor for information on the geometry editor.

Geometry

Shank geometry (Part 1)

Shank geometry (Part 2)

Extruded geometry 

Extrusion thickness

For tools with a free tip geometry, it is not possible to edit the cutting area 
in the geometry editor.

In hyperMILL / in the CAD system 
To define the geometry by selecting contours in the CAD system:

1. Create a new turning tool either using the job definition or in the tool browser. 

2.  Click the icon in the Edit turning tool dialogue (Shank geometry (Part 1) area) to 
select the required contour in the CAD system (warning: the contour should not be 
closed!). If necessary, define the Shank geometry (Part 2) and Extruded geometry in 
the same way.

3. Then define the Mounting point and Reference point for the Extruded geometry.

The Mounting point defines the location where the extruded geometry is mount-
flanged to shank geometry.
The Reference point defines the alignment of the extruded geometry.

The following applies to the extruded geometry of the tool holder: The placement of the              
upper edge of the geometry (mounting point) must be on the coordinate y=0. 

Tool holder geometry parameter
(1) Shank geometry, (2) extruded geometry, (3) extrusion thickness, (4) axis distance, (5)            
shank distance, (6) approach angle, (7) mounting direction: left, (8) mounting direction: right,            
(9) mounting direction: top, (10) mounting direction: inverse.
(11) mounting direction: angle and (12) mounting direction angle are also available for tool             
holders of the recessing tool, axial recessing tool and threading tool types. 
The Side of insert parameter (left, right, top) is also available for inserts of the recessing tool,                
axial recessing tool and parting tool types. For the mounting directions left, right and top, the               
side of insert parameter is pre-set accordingly, and cannot be changed manually.
11-26 hyperMILL



OPEN MIND tool database 1Converting the tool database to the new database Defining a tool  
Tool holder geometry parameters: hyperMILL TOOL Builder
The hyperMILL TOOL Builder calculates the Inclination angle (1) and Rake angle (2), and             
shows it after import in the tool database graphical preview. These cannot be edited here.

Reversed: enable when the insert is to be installed inverted (only with tool holders for              
threaded inserts). (1) reversed not activated, (2) reversed activated
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Advanced tool definition
Y offset (1): for tools with multiple inserts, the Y offset results in the tool moving from the cen-                  
tre position.

Define couplings
1. In the database browser, select the required database entry and then select Cou-

plings... .

2. Select the Coupling type in the Couplings dialogue.

3. Specify a class to which you want the coupling to belong.

4. To do this, right-click in the lower window pane and select New.

5. Define the required geometric parameters and the measurement system for the respec-
tive coupling type and then click OK to close the window.

Coupling types
The following coupling types are available in the tool database:
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Machining adapter
The machining adapter for the tool holder is an impor-
tant component when using machining simulation in 
hyperVIEW. Combinations are only possible when the 
connections fit.

Morse taper 
Geometric parameters:
- Length (1).
Combination conditions:
- can be combined with: Morse taper. 
- names of couplings are the same.

Arbor 
Geometric parameters:
- Diameter, length.
Combination conditions:
- Components with an arbor 
- Identical coupling names 
- Fixed clamping area

Side lock with external thread 
Geometric parameters:
- Diameter, length.
Combination conditions:
- Components with a side lock (internal thread), 
- identical coupling names. 
- External thread completely fits into internal thread,  
- fixed clamping area.

Side lock with internal thread 
Geometric parameters:
- Diameter, maximum length.
Combination conditions:
- Components with a side lock (external thread), 
- identical coupling names, 
- external thread completely fits into internal thread,  
- fixed clamping area.
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Shrink fit 
Geometric parameters:
- Diameter, minimum/maximum length.
Combination conditions:
- Components with a shank or shrink fit 
- Identical coupling names 
- Variable clamping area

Collet 
Geometric parameters:
- Min./Max. Diameter, Min./Max. Length.
Combination conditions:
- Components with a shank or Weldon shank 
- Identical coupling names 
- Drill chuck can be represented 
- Variable clamping area.

Collet with square drive
Geometric parameters:
- Diameter, Min./Max. Length, Min./Max. Square size
Combination conditions:
- Can be combined with: straight shank with square 
drive. 
- names of couplings are the same.

Square drive shank
Geometric parameters:
- Diameter, Min./Max. length, square size.
Combination conditions:
- Can be combined with: Collet with square drive.
- Names of couplings are the same.

Weldon
Geometric parameters:
Diameter, length. 
Combination conditions:
- Components with a Weldon shank 
- Identical coupling names 
- Suitable for Whistle Notch 
- Fixed clamping area.
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Possible coupling type combinations

Coupling types and possible 
combinations
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Adaptor + 
Arbor 
 

- + 

Morse taper - +
Collet 
 

+ + + 

Shrink  
Fit 

+ + 

Side lock with 
external thread 

+ 

Side lock  
with internal thread

+

Collet with square drive +
Straight shank with square 
drive

+

Weldon - +
Weldon shank - + + +
Shank (cylindrical), can be 
defined for each component

+ + 

Combine the couplings with the Holder and Tool components to form an NC tool.
Example:
(A) Holder = holder for a screw-in cutter (e.g., HSK 63 A), side lock with internal thread                
(M12).
(B) Tool = bullnose end mill: diameter (1), radius (2), length (3), tip length (4), side lock with                 
external thread (M12).
(C) NC tool

Weldon shank 
Geometric parameters:
Diameter, Min./Max. Length. 
Combination conditions:
- Components with a Weldon coupling, shrink fit (not 
recommended, because imbalances may occur), collet, 
- Identical coupling names, 
- Fixed clamping area (combination with a Weldon cou-
pling), 
- Variable clamping area (combination with a collet).
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Possible coupling type applications

Tool Extension Holder

Top Bottom Top Bottom Top Bot-
tom

Machining  
adapter

- +

Arbor + + +
Morse taper + + + +
Collet 
 

+ +

Shrink fit - + + + +
Side lock with 
external thread 

+ + + +

Side lock  
with internal thread

+ + + +

Collet with square drive + +
Straight shank with square 
drive

+ +

Weldon - + +
Weldon shank + +
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Technology data 

Technology data and cutting profiles allow you to create tools for special use 
areas. If a tool is to be used for finishing and roughing, define a corresponding 
Usage in the cutting profile and assign this to the tool according to its use.

Technology data can be assigned either to Tools or Inserts. In doing so, the system differen-               
tiates between milling and turning jobs. Thus, individual technology data can take on differ-             
ent values for milling jobs and turning jobs.

Define technology data
1. In the data view, click the Technology tab and set the Cutter material, Cutting edges 

and Spindle orientation.

2. Then, in the lower area of the dialogue box select the required Material and Usage.

The technology data Cutting edges and Spindle orientation are available only 
for tools, but not for inserts.

If an insert with defined technology data is assigned to a tool with technology parameters,              
the technology data of the tool is overwritten with that of the insert.
Information on:

Material and cutter material see section Define material

Technology usages see section Defining a technology usage
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In the OPEN MIND tool database, the following technology data can be defined:

Parameters Explanatory note
Material Define material
Cutter material Define cutter material
Usage Defining a technology usage
Spindle RPM (n) Machining speed
Feedrate XY Feedrate in the work plane
Axial feedrate Feedrate in stepover direction
Reduced feedrate Feedrate for plunge movements into mate-

rial.
Retract feedrate, Feedrate for retract movements (retract 

macro).
Feedrate approach Feedrate for approach movements 

(approach macro).
Feedrate retract Feedrate for retract movements (retract 

macro).
Feedrate stroke Feedrate for stroke movements (Grinding bit 

tool type).
Overlap top Length of the distance that the tool travels 

beyond the machining area in the axial posi-
tive direction.

Overlap bottom Length of the distance that the tool travels 
beyond the machining area in the axial neg-
ative direction. 

F/edge (fz) Feed on the edge.
Cutting speed (Vc) Speed of the tool geometry in the cut direc-

tion through the material to be machined.
Fz drill (f) Feedrate in z direction/rotation.
Max. angle for reduced feedrate Maximum permitted angle of the tool for 

machining at reduced feedrate.
Plunge angle Plunge angle of the tool.
Infeed width (ae) Area of the tool tip used for cutting. Applies 

only to milling tools that do not centre cut.
Infeed length (ap) Length of the cutting edge(s) that is/are used 

for machining the material.
Cutting direction Cutting mode of the tool (climb milling, con-

ventional milling).
Coolants Defining a coolant

The values for spindle RPM and feedrate can be defined using pre-defined or user-defined             
formulas. 
Factor Spindle RPM/Factor F: Factor values that are applied to the spindle RPM and fee-              
drate values of the tool.
Infeed width factor (ae) / infeed length factor (ap): define a factor to modify the infeed width                
(ae) and infeed length (ap) of holders, extensions and NC tools. 
Maximum spindle speed/Maximal feedrate: Limitation of feedrate and spindle RPM. 
5X comp. length: Value for calculating the linear offset as a result of rotating the tool. 

Copy and delete technology data
Copy technology data for tools and inserts by clicking the icon (1). Insert copied technology              
data by clicking the icon (2). Pasting the copied data in the browser is possible for tools,                
inserts and folders in the tools and inserts tab. If technology data that is being inserted that                
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already exists, a prompt is shown asking if the data should be overwritten. Technology data              
sets shall be deemed to exist when material and usage correspond to each other. 
If materials that are in use are deleted, the technology data sets used by the material are                
also deleted. 

Technology

Technology

Technology

<Invariant>

Material

Cutter material

Purpose

Technology data for turning tools 
Retract feedrate: Feedrate used for retract movements. The Retract feedrate is used with            
the Grooving cycle if the tool cannot move freely via the retract macro because of the model                
geometry, but instead retracts along the material (1).
Feedrate reduced: Feedrate for plunges into the material at a specific angle. Application            
cases:

1. Cycle Turning, strategy: Axial, Radial and Contour parallel roughing, Options: Falling 
contours allowed is enabled. Feedrate reduced is always used when a combined X-Z 
movement occurs (2).

2. Cycle Grooving, Strategy: Axial roughing with ramp. The ramping-in movement to the 
next infeed plane always occurs in the Feedrate reduced mode (3).

Technology data for drilling tools 
The following applies to the drilling tools, tap drills and boring bars tool types:

Drilling tool, boring bar  

Cutting speed (Vc) m/min

Fz drill (f) mm/rev

Spindle RPM (n) Cutting speed (Vc) * 1000

pi . d
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Updating technology data
The Cutting speed (Vc), F/edge (fz) and Fz drill (f) technology data can be defined under               
material or in the data view of the tool (Technology tab). 
In the material dialogue, if you set values for this technology data, define a new tool and                
assign a material to it, the previously defined material technology data is linked to the tool               
technology data. 
This means that any change in the material technology data will be adopted automatically             
from the linked tool technology data, including any necessary re-calculation of dependent           
values. 
A linked value, then, can be modified on the tool technology data record only by one factor                
(see 1 in the screenshot and example A).
The link can be removed for each value individually. This way, the tool technology data              
remains unchanged in case of changes to the material technology data (see 2 in the screen-               
shot and example B).
Figure: Data view (tools)

Geometry

Technology

Technology

Cutter material

Technology

<Invariant>

Cutting speed (Vc) F/edge (fz)

Machine steel M1

Cutter material

Material

Usage

Roughing 1 x 2000 0.3

<Invariant>

Example A:
Standard values in the material dialogue:
Cutting speed (Vc) = 200
F/edge (fz) = 0.5
Tool 0001 defined with standard values from the material dialogue: 
Cutting speed (Vc) = 200
F/edge (fz) = 0.5
Standard values in the material dialogue changed to:
Cutting speed (Vc) = 220
F/edge (fz) = 0.6

Axial feedrate Spindle RPM (n) * Fz drill (f)

Tap drill  
Pitch p
Spindle RPM (n) Cutting speed (Vc) * 1000

pi . d
Axial feedrate Speed (n) * Pitch (p)
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For tool 0001, the cutting speed (Vc) changes to 220 and the F/edge (fz) to 0.6. At the same                  
time, all dependent data that is defined using formulas is updated (feedrates and spindle             
speeds).

Example B:
Standard values in the material dialogue:
Cutting speed (Vc) = 200
F/edge (fz) = 0.5
Tool 0001 defined and standard values for material and cutter material overwritten by
Cutting speed (Vc) = 80
F/edge (fz) = 0.3
Standard values in the material dialogue changed to:
Cutting speed (Vc) = 220
F/edge (fz) = 0.6
For tool 0001, the cutting speed (Vc) remains at 80 and the F/edge (fz) at 0.4.
Using the Limiting diameter parameter, the material technology data Cutting speed (Vc), F/            
edge (fz) and Fz drill (f) is assigned to a specific tool diameter (upper limit). This also means                 
that the above-mentioned material technology data is updated if the tool diameter changes            
(see data view of the tool, Geometry tab).

Using standard formulas
1. In the Usage area, select the parameter.

2. Use the combination field to select the required formula.

Technology

Purpose Feedrate XY Axial feedrate

<Invariant>

Material

The  formula icon shows that the corresponding value has been defined 
using a formula. This also applies to the data view of the NC tool.

For the Spindle RPM parameter, there is a formula for the Metric measurement system and              
one for the Inch measurement system.

Defining a new formula
1. Right-click the database entry and select Formulas.... 

2. In the Formula combo box, select the area for which you want to define a new formula.

3. Right-click in the Formula dialogue box and select New.

4. Enter a name for the new formula (1), double-click the Formula column (2), click the 
icon for displaying the formula elements (3), define the formula you require (4) and 
select OK to close the dialogue.
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Comment
Default infeed formula.

Name Formula

fz - feedrate per tooth

fFinfeed fz*z*n/3

z - number of cutting edges

Vc - cutting speed

Formulas can be used in all numeric input fields.
Example: Diameter: (5+2)*3 = 21.

Only points, but not commas, are allowed, as decimal separators in formulas. 
Only certain variables are allowed for formula definition, depending on the for-
mula type. The following limitations shall apply: 
Speed: spindle RPM (n) is not acceptable. 
Length: ae, ap, fz, z, Vc, n and f are not acceptable. 
Feedrate: all variants are allowed. 

Define material
1. Select the database entry in the database browser and then select the Materials... 

menu item.

2. Right-click in the Materials window and select New.

3. Enter the name of the material you require and, if necessary, enter a suitable comment. 

The material name must be unique. Otherwise, you will get an error message 
when closing the window.

Because the cutting conditions for the tool are largely affected by the cutter material, you can               
assign a defined cutter material to each material in the cutter material dialogue. 
For information on assigning cutter materials to materials, see section Assigning a cutter            
material to a material.

Define cutter material
1. Select the database entry in the database browser and then select the Cutter Materi-

als... menu item. 

2. Right-click in the Cutter Materials window and select New.

3. Enter the name of the cutter material you require and, if necessary, enter a suitable 
comment.

Assigning a cutter material to a material 
In the lower part of the Materials dialogue box, you can assign each material one or more                
cutter materials. 
In such assignment, a distinction is made between the two measurement systems Metric            
and Inch as well as between milling and turning technologies.

Assigning material to cutter material
1. Select the material and then define whether the material-cutter material combination is 

to be used as milling technology or turning technology with a metric or inch-based 
measurement system.

2. Click icon 1 and select the required Cutter material from the list.
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Default milling technologies

Default turning technologies

Metric

Metric

CommentName

Inch

Inch

For each cutter material, you can define the Limiting diameter, Cutting speed (Vc), F/edge             
(Fz) and Fz drill (f) parameters as well as a measurement system.
Depending on the tool diameter, the F/edge (Fz) feedrate defined for the (upper) limiting             
diameter of the cutter material and the cutting speed (Vc) are incorporated into the definition              
of the tool.
Example:

Material Cutter material Limiting diame-
ter

fz Vc

1.30255 (Al 99.5) SC (Solid Carbide) 10 0.3 250

1.30255 (Al 99.5) SC (Solid Carbide) 20 0.4 265

1.30255 (Al 99.5) SC (Solid Carbide) 30 0.6 280

Taking technology parameters from the cutter material for an NC tool 
To apply the F/edge (fz) and cutting speed (Vc) technology parameters from the cutter mate-              
rial definition for an NC tool, follow the steps below:

1. Define a material and cutter material (including a limiting diameter, fz and Vc).

2. On the Tools tab, select the tool you require or define a new tool. 

3. In the Technology area, select the relevant material and the associated cutter material 
and select Standard as the purpose.

4. Based on the sample data contained in the above table, a defined tool diameter of 15 
results in the value 0.4 for the F/edge (fz) parameter and the value 265 for the Cutting 
speed (Vc) parameter (see the table).

Defining a technology usage
Assign different technology parameters to a cutter material, depending on the machining sit-            
uation (e.g., roughing or finishing). This assignment is made in the data view of the tool defi-                
nition in the technology parameters area (Material > cutter material).

1. Select the database entry in the database browser and then select Technology Usages.

2. Right-click in the Technology Usages window and select New.

3. Specify the Usage and, if necessary, enter a comment.

Save as default 
1. Click the Technology tab of the tool’s data view.
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2. In the lower area of the dialogue box, select the required Material and click the Usage 
entry.

3. Select the usage and then click the icon (1). 
All of the technology parameters defined for this purpose (including all of the formulas used)              
are saved in the default purpose.

Geometry

Technology

Technology

<Invariant>

Technology

HM 2015

Machine steel M1

Cutter material

Material

Usage

Roughing

If you then insert a new material in the data view of the tool, the parameters previously saved                 
in the default usage will always be used.

Defining a coolant
To define a new coolant:

1. In the database browser, select the required database. 

2. Right-click and select the Coolant function on the shortcut menu.

3. The two coolants with the ID 1 and ID 2 are already predefined by default. Right-click 
and then select New. Newly added coolants are numbered consecutively (ID 3, ID 4...).

4. If necessary, enter a comment for the coolant properties or coolant type.
You can define up to nine different coolants. 

Assigning coolant to a usage
1. In the data view of the tool, switch to the Technology tab.

2. Under Material > Usage > Coolant, click icon 1 and open the Coolant dialogue.

3. Activate the coolant intended for the usage. 
The IDs of the activated coolants are displayed (2).

Technology

Feedrate XY

<Invariant>

Machine steel M1Material

Usage

Roughing

1, 2 ,3 

Coolant 
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Define spindle
1. In the database browser, switch to the Spindles tab. 

2. Right-click the database entry. 

3. Select New spindle and specify a Name, if necessary, a Comment (tooltip) and the 
Measurement system for the spindle.

4. To link the tool spindle with other components, specify the Type and Class of the lower 
Coupling. Start the geometry editor in order to specify the spindle geometry.

Define holder/extension
1. In the database browser, switch to the Holder / Extension tab.

2. Select the database entry you require and then select New Holder/New Extension. 

3. Give the Holder / Extension in the data view a unique Name and select a Measurement 
system. 

You can also save the components Spindle, Holder and Extension as default. All the geome-              
try and technology parameters are saved and used if you define this component again.
To save a component as default, select the component in the database browser and select              
Save As Default in the shortcut menu.
Information on

Technology parameters see section Technology parameters

Couplings see section Define couplings

Geometry editor see section The geometry editor

Importing a holder/extension as a 3D model
Use the hyperMILL TOOL Builder to import a holder or an extension from an existing 3D               
model (format: *.stl). 

In the Geometry area, open the hyperMILL TOOL Builder. 

For information on the hyperMILL TOOL Builder, see the hyperMILL TOOL Builder product            
documentation.

For 3D geometries of holders and extensions, it is no longer possible to 
edit the profile in the Geometry editor.

The geometry editor
Use the geometry editor to create freely definable geometries for tool components. 
Click the Geometry line in the data view of the component and then click the icon (1). Specify                 
a name for the geometry and define whether you want the geometry to be active and               
whether a coupling exists. To edit an existing geometry, click the icon (2) and open the               
geometry editor.

Geometry

Variant 1

Name

Active
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Only one geometry can be active for each component. You cannot delete an 
active geometry. To delete a geometry, disable this and use the icon (3).

The geometry editor comprises an input area for defining line segments and a graphical pre-              
view (2D). To add a geometry, right-click in the input area and specify the Height for the Ori-                 
gin and the Diameter and Height for the line segment. Add a line segment using the Paste                
shortcut menu.

Type Diameter Height Report

Edit

Origin
Line

Line

Line
Paste

Delete

Since the component geometries are always rotationally symmetrical models, 
you can uniquely define a line segment by defining a Diameter and Height. The 
radius is displayed in the graphical preview.

Component geometries must not contain any undercuts in the X direction. 

Enable the checkbox in the Report column to copy the line segment to a report. The first and                 
last line segment are always selected by default, so that they are output in a report. 
If the check box in the Report column is enabled, its dimensions are also displayed in the                
geometry editor. The same also applies to the components Spindle, Holder and Extension. 
To edit or delete a line segment, right-click in the input area and select Edit or Delete.

Load: Load a contour from a dxf file. 

The following requirements must be met in order to be able to correctly load the dxf file: 
• The contour must be on layer 1, 
• the contour must be closed, 
• both halves must be present for rotating bodies.
• The axis must be horizontally aligned.

Insert: Insert a contour in the *.omx format and import freely defined tool 
geometries directly from hyperMILL, for example.

Copy: Copy a contour from the database to the clipboard. 

Mirror: Mirror a contour.

Delete: Delete a contour.
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Complete your entries by clicking OK. A contour is now displayed in the graphical preview as               
a 3D bounding geometry. 
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Defining an NC tool
1. In the database browser, switch to the NC tool tab.

2. Select the database entry you require and select New > NC tool.

3. The Select Tool dialogue box opens. Here, select the tool you require and then click 
OK.

4. The newly created NC tool appears in the data view. Here, specify the required compo-
nents and parameters. 

Or:

1. Switch to the Tool tab in the database browser.

2. Select the tool that you want to use to define the NC tool and select Create NC-Tool.

3. In the data view of the NC tool, define the components and parameters you require. 
The data view of the NC tool is divided into the Geometry and Technology tabs. On the                
Geometry tab, specify the general characteristics (NC number, Name) as well as the compo-             
nents that make up the NC tool. On the Technology tab, define the material used and the                
cutter material, the usage as well as the spindle speed and feedrates. If these have already               
been defined for the tool, they can be overwritten for the NC tool.

Save NC tool as default
To save a NC tool as the default, select the desired NC tool and select Save as default from                  
the shortcut menu. This will also save reference points. 

Basic parameters
The NC number (maximum: 10 digits) is transferred to the NC file and is used to identify the                 
tool on the machine that is used. For machines that can also evaluate non-numeric charac-              
ters, hyperMILL also allows you to use an ID to define any combination of digits/characters              
(maximum: 32 characters) in order to uniquely identify the tool.
The tool type and measurement system are taken from the selected tool. 

Select tool, spindle, holder and extension
NC tools are created in the data view of the overview window. Here, you can select the spin-                 
dle, holder, extension and tool components for a newly created NC tool.

1. In the data view of the NC tool, click the Holder, extension, tool entry or on the icon (1), 

2. click on the icon (2) or (3) to select the desired component,

3. confirm the selection with OK .

Spindle

Geometry Technology

Holder

Extension

Tool

Tool reach

When assembling an NC tool, the following conditions apply:

1. The measurement system of the selected tool determines the measurement system of 
the NC tool.

2. All installed components must have the same measurement system.
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If you assign a holder, extension or tool to an NC tool, only those components 
that can actually be installed at the appropriate place are displayed in the rele-
vant selection dialogue boxes. 

To connect components with each other, you use couplings, which can be categorised in the              
tool database according to different basic types and can be installed according to classes.

The coupling types used and the size of each coupling (length, diameter) deter-
mine which components are assembled together to form an NC tool.

If you use the holder or extension component when assembling an NC tool, hyperMILL also              
checks the maximum spindle RPM of the components and takes the lowest value for the NC               
tool.
Example:

Holder 10,000

Extension 7,500

Tool 15,000

NC-Tool 7,500

Geometry parameters
(1) Spindle, (2) holder, (3) tool, (4) clearance length, (5) NC tool length, (6) tool reach, (7)                
tool length, (8) shank diameter, (9) tip length, (10) chamfer length, (11) tool diameter.

Gage point offset: Represent elements that extend beyond the standard geometry used in            
the vertical direction when assembling the NC tool and milling spindle. These can be: 
• Elements of the milling spindle such as coolant nozzles.
• Elements of the holder such as a fixture cone.
The following figures show the parameters for Milling spindle, Holder and Tool (NC tool):
(1) Milling spindle
11-45hyperMILL



OPEN MIND tool database1 Defining an NC tool Save NC tool as default    
2 = Gage point: Used when connecting the tool to the machine to determine the Gage point                
offset (milling spindle/holder) and to calculate the NC tool length. 
(3) = Gage point offset (milling spindle): As a parameter of the milling spindle, this describes               
the offset from the gage point to the lower edge of the spindle elements which extend               
beyond the gage point (e.g., cooling nozzles). 
4 = Holder  fixture cone
(5) Holder
(6) Gage point offset (holder): As a parameter of the coupling, this describes the gage point               
offset to the geometric upper edge of the holder (fixture cone). The Gage point offset is only                
available for the Adaptor coupling type.
(7) = Gage length: Length from the tool tip to the gage point.
(8) Tool

Technology parameters
To define technology parameters for an NC tool, switch to the Technology tab of the data               
view.
If Spindle RPM (n) and Feedrates have been defined for a material, they can be overwritten               
in the data view of the NC tool and, if necessary, modified through the use of factors.
For information on defining cutter materials, see section Define material.
Tool reference
For the following tool types, either a tip or centre can be set as the tool reference: 
Ball mill, bullnose end mill, lollipop, Woodruff cutter and lens cutter.
Tip (1): Z positions in the NC program are relative to the tool tip.
Centre (2): Z positions in the NC program are relative to the tool's centre point.
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You can define several reference points for the following tool types:
T-Slot Cutter Drilling tool, Tap Tool and Boring bar:.
For the Barrel cutter tool type, only the tip reference point is supported. 

 Reference points
Specify the name and position of the reference point. You can define as many reference              
points as needed.
Example
The value of the reference point position always refers to the tool reference (see the image).               
R1: Position = 2, R2: Position = -2, Tool reference = 1

A positive value for the reference point means that this point is moved two units in a positive                 
direction on the Z axis. 
A negative value for the reference point means that this point is moved two units in a nega-                 
tive direction on the Z axis. At the same time, the clearance plane is aligned accordingly.
An offset of 0 corresponds to the tool reference.

The tool reference must match the tool's measuring system and applies to all 
5X and 3D jobs in a joblist.

Factor spindle RPM (n) / Factor F: can be defined irrespective of the material and they are                
multiplied by the Spindle speed / Feedrate values. The Maximum spindle RPM and theMaxi-             
mum feedrate limit the spindle RPM and feedrate values. 

Both the factor values and the maximum spindle RPM or maximum feedrate 
also apply to the holder and extension components.
Factor values are also applied to Feedrates in the cutting profile if the feedrate 
unit is set to mm/rev or inch/rev. 

5X comp. length: Value for calculating the linear offset as a result of rotating the tool. The                
distance from the tool reference point to the pivot point is normally composed of a tool-inde-               
pendent and a tool-specific part (correction length).
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Usable length: For drilling tools and tap drills, the value is determined as follows: cutting              
length - tip length (drilling tool), cutting length - lead in length (tap drill). The value can be                 
modified later on. 
The following applies for all other tool types: Usable length (5): Determined based on the              
Tool diameter (1), Tip length (2), Tip angle (3) and Lead in (4) parameters. Tip angle (3) and                 
Lead in (4) are calculated based on factor values

Tip angle (3) Tip length / Lead in length (4)

80° 0.6 * D (Tool diameter)

118° 0.3 * D (Tool diameter)

130° 0.23 * D (Tool diameter)

140° 0.18 * D (Tool diameter)

.

Tool diameter (1), Cutting length (2), Tip angle (3), Tip length, Lead in length (4), Usable               
length (5)

For milling tools the following also applies: Usable length = Tip length. If the tool reach is                
lower than the tip length, the usable length corresponds to the cutting length.
NC tool length: tool length + holder length.
The technology values for the cutting edges and spindle orientation are taken from the             
selected tool. 

Material
A material and usage are always displayed if they are linked with the selected cutter material               
(see above). The material and usage are then taken from the selected tool. 
The material-dependent spindle speed and feedrate values such as Spindle RPM (n), Fee-            
drate XY, Axial feedrate, Reduced feedrate as well as the Infeed width (ae), Infeed length              
(ap) and Plunge angle parameters can be directly overwritten for the NC tool. 
To directly overwrite these material-dependent parameters, click the corresponding row (1).          
If the value is linked, first click the icon (2) to clear the link. Then enter the desired value.

Material

Spindle RPM (n) Feedrate XY

Machine steel M1

Purpose

Roughing

Coolant Additional coolant
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Meaning of the icons

A formula is used to define a value for the tool.

The value has been overwritten for the NC tool.
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Cutting point setup (turning tools)
Specify the clamp of the tool and the position of the cutting edge using the Tool angle, Tool                 
reference, Cutting edge position and Reference angle parameters.
The parameters are saved in one parameter set. It is possible to name, copy and paste a                
parameter set. You can create as many parameter sets as desired for a tool. 

Parameter sets

 Parameter sets: Define a new turning parameter set.

 Location: Delete location / copy location to clipboard.

Name location.
Tool angle: Specify depending on the type of machining. Inside (1), outside (2). Default set-              
ting = 90°.

Tool reference: Specify the tool reference for calculation of the toolpath using the Free point              
definition, Contact point, Orthogonal gauge point or Primary centre options.
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Free point definition (A): Define any reference point. Use the Mounting point x offset (1) and               
Mounting point z offset (2) parameters.
Orthogonal gauge point (B): Select the Cutting edge position parameter using the buttons (3)             
for machining operations with path compensation (G41/G42). Defines the location of the ref-            
erence point relative to the Mounting point (centre point) of the insert. 
Primary centre (C): The radius of the insert is used as a reference point (4).

Correction list: Correction space in the machine.
Invert tool: Function not enabled (1), function enabled (2).

Advanced
Reference angle (1): Turn the tool holder and insert around the own axis in the tool angle                
(overhead setup). No graphical preview available.
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Depots 
Use depots to group and administer tools according to your own criteria.

Defining a depot
1. Go to the Depots tab in the database browser. 

2. Right-click the database entry, select New > Depot and specify a Name and, if neces-
sary, a Comment (tooltip) for the depot.

3. Enable the Contains NC tools option if you want the depot to contain the NC tools.

Saving NC tools in a depot
1. Select the relevant depot and right-click the entry. 

2. Select New > Depot Item... 

3. In the Select NC Tool dialogue box, select the tool you require and confirm by selecting 
OK.

or:

1. Select the required tools on the NC tool tab,

2. select the Create Depot Items... function from the shortcut menu. 

3. In the Select Depot dialogue box, select the depot you require and confirm by selecting 
OK. 

The NC tools are now available in the depot and the parameters are displayed in the data                
view. If some of the NC tools already exist in the respective depot, these are not added and                 
a corresponding message is displayed.

The Create Depot Item... function is also available for entire folders. It enables 
you to transfer the content of an entire directory to a depot.

NC tools are indicated by an alternative NC number, an alternative NC number (with text)              
and an alternative NC name when they are added to a depot. These initially correspond to               
the NC number, ID and Name.
You can, however, change these manually: if you create a depot as a magazine, for exam-               
ple, the alternative NC number can be used as the place number of the tool. This number                
therefore always needs to be unique. 
If you transfer tools from a depot directly to hyperMILL, the Alternative NC-Number is trans-              
ferred as the Number and the Alternative NC-Name as the Name in the tool browser. 
To transfer an entire depot or individual tools from a depot to hyperMILL:
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1. Select the required entries, right-click and

2. select Transfer to hyperMILL.

Transferring a function to hyperMILL is only available if you start the tool data-
base from the hyperMILL browser.

How to create a new depot within an existing depot:

1. Select the relevant depot, right-click and

2. select New > Depot.

Exchanging data with other databases
To exchange data with other tool databases, a neutral format (*.xml) is available.
You can import or export both an entire database and individual folders or elements. 
For more information on the XML data exchange format, please contact your OPEN MIND             
partner.

Importing/exporting data 
1. Select the required database entry in the database browser.

2. Select Import or Export on the shortcut menu.

3. Then choose Neutral Tool Exchange Format (*.xml). for file type.
Please note: the Import shortcut menu function is only available for database nodes.

Exporting a structure
To export just the folder structure of your OPEN MIND tool database: 

1. Select the element you require (database or individual folder) in the database browser 
and

2. select the Export structure option on the shortcut menu.

Synchronization
The Synchronization function allows data to be compared automatically between another          
database system (such as Walter) and the OPEN MIND tool database.

1. In the database browser, select the database into which you want to import the data of 
another system.

2. Select Synchronization > Input from the shortcut menu.

3. Click the Enabled checkbox in the Input Synchronization dialogue.

4. For Data exchange folder, select the folder that contains the database whose data is to 
be synchronized with the OPEN MIND database.

5. Enable the Slave database option (OPEN MIND database). Please note: if this option is 
enabled, you cannot edit the contents of your OPEN MIND database. Enable the Pre-
serve folder structure option to preserve the folder structure of the OPEN MIND data-
base when synchronizing the data. 

6. For Workstation ID, click Update , to read the ID of the system on which your OPEN 
MIND database is located.

Additional functions

Generating reports
Generate report files with the parameters of the defined tools and/or tool components. You             
can generate reports for tools, NC tools, extensions, depots and holders. 
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1. Select the element you require in the browser (you can also make multiple selections). 

2. Right-click and

3. select Report... from the shortcut menu . 
The data is initially temporarily saved in the *.html format and displayed in your default              
browser. You can now back this data up anywhere on your system.
The creation of reports can be controlled from the Options > General menu.

Show report after generation
The generated report file is opened automatically in the default program.

Overwrite report output folder
When creating a new report, an existing report directory is deleted and a new directory is               
created. By default, reports are saved in the [tooldbReport] directory of the Global working             
space. If you use project paths, they are saved to the [tooldbReport] directory of the project               
path defined. 
For information on creating reports, see section ReportDesigner. 

Specifying the accuracy
You can specify the accuracy for both the metric and inch measurement systems, as well as               
separately for angles and factors.

1. Right-click the required database in the database browser and

2. select Accuracy from the shortcut menu.

3. Specify the corresponding accuracies for the measurement system used and for the 
angle and factor.

4. Alternatively, you can specify the accuracy via the menu by choosing Options > Accu-
racy.

Specifying a measurement system
1. Right-click the required database in the database browser and

2. select Measurement system > Metric / Inch from the shortcut menu.

Changing the password
1. Right-click the database entry in the database browser and

2. select Change password from the shortcut menu.

3. Enter the old password, then specify the new password.

4. Confirm the new password.

Showing properties of the tool database
1. Right-click the required database in the database browser and

2. select Properties... from the shortcut menu.
The following properties are displayed: File name, User, Version and URL.

Defining a filter
Filter the display of elements in the browser window and in the data view according to certain                
criteria. 

Folder

Database
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1. Click the icon (1) to open the Filter dialogue.

2. In the Filter dialogue, select and activate the filter. To do this, enter the required values 
or select one of the options offered.

The column width in the list display depends on the tool type and the activated (displayed)               
options. For information on configuring the list display, see section The browser. 

Deleting a filter
Click the icon (2) to delete the defined filter.
If you start the OPEN MIND tool database from the Tool dialogue page of the job definition,                
previously defined tool types are also considered as filters. Please note that when you delete              
a filter, this default filter in hyperMILL is not taken into account. 
If you start the Select NC-tool dialogue from hyperMILL, the filter in the Technology area              
contains a complete list of all materials already defined for the material selection.
If you clear the check box in the middle column of the Filter dialogue box, the respective filter                 
is also disabled; however, the filter definition remains the same. 

Multiple selections
Select multiple elements in the browser at the same time. To do this, click to select the                
required elements and hold down the CTRL key at the same time. Depending on the type of                
elements selected, different functions are available in the shortcut menu (right-click) (includ-           
ing Copy/Export). 
You can also use the multiple selections function to transfer several tools to hyperMILL. For              
further information, see section Import tools from external database.

Copy & Paste
In the browser of the OPEN MIND tool database, move or copy elements to a different place                
in your database using drag-and-drop operations. 
To move an element, select the required element with the left mouse button and move it to                
the required location while holding down the mouse button. 
To copy an element, hold down the CTRL key at the same time. This function is available                
both for elements and for folders.
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Interfaces 

TDM Systems integration

Manage the exchange of data with the TDM Systems tool management 
system using the TDM Systems integration.

Select the TDM Systems database from the hyperMILL > Setup > hyperMILL Settings >             
Database > Settings Wizard dialogue.

Importing tools from TDM Systems to hyperMILL

1.  Click the icon to start the TDM Tool Manager. This can be done either directly in 
the job definition tool dialogue, from the hyperMILL browser or from the hyperMILL > 
Tools menu. 

2.  The tool import dialogue is already enabled by default.

3.  Click on the tool icon to first select the desired 
tool type, and then the tools to be imported. If the TDM Tool Manager was opened from 
the job dialogue, then only the tool type already selected in the job dialogue is selecta-
ble.

It is not yet possible to import turning tools with hyperMILL Version 2017.1. 

Tools which were imported using the TDM Tool Manager can be used in macro 
programming. A prerequisite is that the tools are saved in the database as an 
NC tool with a unique ID. 
In the Apply macro dialogue, NC tools used in macro jobs which come from the 
tool database and have a unique ID are marked as DB.

Exporting a tool list from hyperMILL to TDM Systems
1. Open the TDM Tool Manager from the hyperMILL > Tools > TDM Systems Tools menu. 

2.  Click the icon to open the Tool list export dialogue. All local tools defined in the 
model file (*.hmc) will be exported.

3. Define the name of the tool list to be exported using List ID.
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WinTool integration
The WinTool integration enables data exchange with the WinTool tool management system           
and is available via the hyperMILL > Tools menu.
It is possible to access complete tools and tool lists directly from hyperMILL. The tools              
exported from WinTool are not written to the OPENMIND tool database, but directly to the              
hyperMILL document. This way, a redundant tool management system is avoided.
To enable the WinTool integration, right-click in the CAD toolbar and select the WinTool             
hyperMILL interface.

To enable the WinTool integration, right-click the 
CAD program's toolbar and select the WinTool 
hyperMILL interface option.

WinTool hyperMILL data exchange
During the exchange of data between WinTool and hyperMILL, the existing tool IDs are             
checked. 
When importing tools from WinTool, hyperMILL assigns NC numbers automatically. The          
next NC number is the highest existing number + 1. 
Using the WT-MakeList function, all tools used in a hyperMILL document are adopted in a              
list and exported to WinTool. The list consists of a set of IDs and NC numbers for each tool                  
used.
For more information on the functions of WinTool integration, see your WinTool documenta-            
tion.

Zoller integration
The Zoller integration enables data exchange with the Zoller tool management system and is             
available via the hyperMILL > Tools menu.

Import Zoller tools: Opens a window of the Zoller database to choose the 
tools that are to be imported to hyperMILL. The imported tools are automati-
cally entered in the tool list of the current document.

Export Zoller tools: All tools used in the document are exported to the Zoller 
database. If the document contains multiple joblists, a usage list is created 
for each joblist of the document

Import and export are available only if the Zoller TMS has been started.

 

Only hyperCAD 2009.3: Optionally, display the buttons for the inter-
face. To do this, right-click the toolbar, use the Adjust function to open 
the Toolbars dialogue and enable the Zoller TMS hyperMILL option.

Icons in the database browser 

Milling Tools Drill Tool Turning tools

  Ball endmill   Drilling tool   Turning tool

  Endmill   Tap drill   Recessing tool

  Bullnose endmill   Threadmill   Axial recessing tool
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  Lollipop   Boring bar   Parting tool

  Woodruff cutter   Countersink   Threading tool

  Barrel tool   Reamer   Touch probe tool 

  Chamfered cutter
 

  Grinding bit

  Chamfered profile cut-
ter

  

  T-slot cutter
  

  Lens cutter
  

  General barrel tool

  Conical barrel tool

  Tangential barrel tool

Production resource Other Inserts

  Cutter material   Depot   Rhombic insert

  Material   Holder   Triangular insert

  Couplings   Extension   Round insert

  Technology usage   Depot element   W-shape insert

  Coolant   Tool holder   Threading insert

  Formula   Spindle   Simple thread insert

 
  NC tool   Rectangular insert

  Parting insert

  Free form insert

Milling Tools Drill Tool Turning tools
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hyperVIEW 
Structure of documentation

This documentation provides you with:
• A brief overview of the basic functions in the following section.
• Information on the screen layout in section User interface.
• A brief summary of the most important workflows in section Important workflows.
• Detailed descriptions of the individual functions on the menu in section Menu functions.
• Descriptions of the hyperVIEW browser functions in section Functions in hyperVIEW 

browser and 
• information on the toolbars in section Toolbars.

Basic functions
hyperVIEW's basic functions include:
• Display of the toolpaths and control of the tool's movements (Toolpaths).
• Machine simulation based on toolpaths (Setting up the machine simulation).
• The generation of NC files (Generate NC program).
• The generation of reports (Generating reports) and
• print functions (Printing information).
To unlock some of the hyperVIEW functions described here, you will need to purchase a              
special licence. Please contact your OPEN MIND dealer. With the relevant licence, you can             
also simulate multi-axis and 5-axis machining.
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User interface
The user interface consists of the following elements: 
(1) Menu bar, (2) Toolbars, (3) Browser, (4) Graphics area, (5) Status bar 

Important workflows
Important workflows are outlined below.

Defining a machine
For much of the work carried out, you need to specify a machine to use for simulations.                
When you run hyperVIEW for the first time, you will be prompted to define a machine.
Proceed as follows to set up a machine:

1. Open the Machine administration dialogue. 

2. Alternatively, open the Machine administration dialogue via the joblist in hyperMILL 
(Postprocessor > Machine).

3. Specify the machine's name and postprocessor in the Common category of the 
Machine properties dialogue.

The postprocessor's parameters need to be suitably configured before it is used 
for the first time. Please contact your OPEN MIND dealer to get information 
regarding this.

Proceed as follows to modify a postprocessor's configuration:

1.  Open the Postprocessor configuration dialogue and, if necessary, change the 
name, type and value of individual parameters.

2. Make sure to document all changes made in the configuration dialogue!
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Model mode: Specify whether a machine model is to be used for the simulation or whether               
only the part and tool are to be displayed. If a machine is used, define the format of the                  
machine model file.
Model from MMF file / VMM file: Select if a machine is to be displayed in hyperVIEW. Click                 
the icon 1 to select the machine model file. The settings for Model from VMM file correspond                
to the settings for the Fixed part option. 

Model mode Model from MMF file

Model file

Model from postprocessor: Select if the postprocessor (*.oma) contains a machine model.           
Only licensed tool machine models can be used. For more information on this, please con-              
tact your OPEN MIND partner.

Please note that these machine models are not assured to match any particular 
machine in your machine shop. Functions like collision control and workspace 
monitor may vary from our typical model to your actual machine. 
OPEN MIND or your OPEN MIND partner can adjust the machine to your par-
ticular requirements. This service, which does not form part of the standard 
delivery, is charged separately.

Fixed part / Fixed tool: Select if there is no machine model or if the machine model is irrele-                  
vant to the simulation. Only the part and the tool are displayed in the simulation; one of the                 
two needs to be fixed.
For further information on the Machine definition dialogue and on how to configure a post-              
processor, see section Machine Properties / NC-File properties.

Generate NC program 
Proceed as follows to write an NC file:

1. Define a machine, see Defining a machine.

2. Create an NC job (right-click > Create NC job). hyperVIEW creates an entry in the 
browser consisting of the following elements: machine, several parts (stock, model, 
result) and toolpaths.

3. Insert a toolpath (select the Toolpath entry in the browser, right-click and select > Insert 
toolpath).

4. Start the postprocessor run (select the NC job entry, right-click and select > Write NC-
File).

The postprocessor run terminates with an error message if no licence is found.

OPEN MIND has enhanced the postprocessor run to include an analysis of 
the postprocessor. The following message appears if a security-related issue 
is detected: 
Important note on your postprocessor. OPEN MIND detected a security 
issue. Please contact your OPEN MIND business partner. 

Setting up the machine simulation
Proceed as follows to set up the machine simulation: 

1. Define a machine, see Defining a machine.

2. Create an NC job and insert toolpath (see section Generate NC program).
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3. Define the machine simulation conditions. To do this, switch to the Simulation tab in the 
browser and define the machine origin, the movement display of your choice and the 
speed (animation control).

Machine origin: If you select the Automatic option, the parts used and the tool-
paths are positioned automatically. Use Machine Setup to define other origins.

4. Define the display options for the tool, toolpath, machine and model.

Animation control
C: All the tool movements of the respective job are simulated.
G1: Only the tool movements on the G1 plane are simulated.
G0: Only the tool movements on the G0 plane are simulated.

If you set the (Program) halt option to On, the simulation will be stopped at the 
point specified in the NC file.

Mode
If you want to perform a material removal simulation, define a stockmodel. 

Material removal simulation disabled. Open the Create stock dialogue. Define 
the shape and display for the stock.

Material removal simulation enabled (only if a stockmodel has been defined).

Material removal shaded

Material removal transparent

Material removal wireframe

Save the result of the material removal simulation in the*.stl, *.vis or *.omg for-
mat.

Model shaded

Model transparent

Model wireframe

Model invisible

Automatic collision checking disabled.

Automatic collision checking enabled.

Enable collision checking to include the activated checks. A reverse simula-
tion is not possible.
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For information on the machine origin, animation control and the display mode for the simu-              
lation, see section Simulation tab.

Generating reports
Generate a report for tool lists, joblists or statistical information (tool movements, dwell            
times, coolants and so on) in the formats *.htm , *.rtf , *.txt or *. xml (for Excel 2002).
Proceed as follows to create a report:

1. On the File menu, select the Report entry or select the NC job entry in the browser, 
right-click and select the Report option.

2. In the Report dialogue, select the required format and a template file.

3. Specify a path and file name and save the file.
For the generated report file to open automatically, you need to select the Show report after               
generation option on the Options > General menu.

Reports including statistical evaluations can only be created if in hyperMILL (job 
definition > General dialogue page) the Generate NC file option is enabled.

Open the Machine structure dialogue.

Machine component visible.

Machine component invisible.

Show all machine components.

Hide all machine components.

Tool shaded

Tool transparent

Tool as wireframe

Tool invisible

Display all toolpaths.

Only display the current toolpath.

Only display the current tool movement.

Do not display any toolpaths.

An activated machine model is required to display the machine.
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Use a text editor to customise script files (*.JLR) for modifying the content of report files               
according to your individual requirements.

Printing information
Print information on the NC file, machine, tool parameters and machining cycles for an NC              
job.

Defining the print layout
To define the print and CSV layout:

1. On the Options menu, select the Print and CSV Layout entry.

2. Select the <new layout> option and specify a name.

3. Define the printing values (double-click the Available values column).

4. Use the arrow keys to specify the order of the values.

5. Click OK to confirm the print and CSV layout.

Print
To print the layout:

1. Select Print from the File menu. 

2. In the Print dialogue, define the printer, print area and layout.

3. Click OK to close the Print dialogue.

To print out NC jobs, the browser window needs to be active, as otherwise the 
current contents of the graphics window will be printed instead. 

CSV format: The defined parameters are saved in a text file with comma separators between              
the values.

This format enables further editing in a spreadsheet program such as Excel.

To generate a file in *.CSV format:

1. Select CSV from the File menu.

2. Select the storage location, file name, file type and layout. 

3. Click Save to close the dialogue.

Menu functions

File
Open: Use this command to open files (file types *.hv or *.hvz). When opening *.hvz files, the                
files contained in the archive are unpacked to a temporary directory (tmp).

This automatically deletes all browser entries. 

Append: Use this command to append the selected file (*.hv / *.hvz) below the last browser               
entry. Existing entries are not deleted.
Save as: Save a file in the format:
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• *.hv: With this file type, information about the machine, stock, model and toolpaths is 
linked to an NC job. All of the NC jobs in the browser are saved.

This gives you the option of saving a project (NC file) even if you haven't yet 
defined all the areas. Missing data can still be added at a later point.

• *.hvz: All of the files associated with a project file (*.hv) are saved together in a ZIP file 
with the following file structure: 

NC-Job X
- 3DF/
- POF/
- STOCK/
- NC/
NC-Job Y
With postprocessor: Include the postprocessor in the .hvz file. This includes all *.def files that              
are located in the same directory as the postprocessor (.oma file).
With machine model: Include the machine model in the .hvz file.
The options are important for the OPEN MIND support team and are enabled by default.  
Unpack Archive: Unpack all the files associated with the project file (that is also contained in               
the ZIP archive) to the selected directory.
Report: Open the Report dialogue. It is possible to output tool lists, statistical evaluations             
and job list reports; to some extent also with a graphical representation of the toolpaths. The               
following file formats are available: HTML, RTF, TXT and XML (Excel 2002). Select the file              
type and report required, confirm your selection by clicking OK and then enter the path and               
file name to save the report file. A report file is generated for every NC job in the browser. 

Move the report to the top of the list.

Move the report one line up.

Move the report one line down.

Move the report to the bottom of the list.

Create a new report.

Edit the report.

Delete the report.

Save to project folder: Save a report directly in the Joblistreport folder inside the project fol-               
der. 
CSV: Save to a file in the *.CSV format using parameters which were selected in the Print                
and CSV Layout dialogue (Options menu).
Print: Open the Printer setup selection dialogue to print data for the NC job selected in the                
browser.
Page Setup: Specify the page options for printing (default Windows dialogue).
Write NC-File: Create NC files for all of the NC jobs selected in the browser. Before the NC                 
file is generated, you can still edit and change the relevant tool data and the stock. For fur-                 
ther information, please refer to NC file. 
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Edit
New NC-Job: An empty NC job (data format: *.hv) is created in the hyperVIEW browser and               
assigned the following (tree structure): machine, stock, model, result, rest material, clamp           
and toolpaths.
The default machine is the one specified in the Machine Administration dialogue box. The             
Machine Definition dialogue box also specifies the name of the NC job.
Delete all NC-Jobs: Delete all the NC jobs created in the hyperVIEW browser.
Machine administration: Opens the dialogue for creating and editing machines.

Machine 1

The default machine specified in Machine Administration is also displayed in the Machines            
toolbar.

By default, the Machines toolbar is hidden when the program is first started.

View
Display: Option to display frames, NC systems and world coordinate system in the graphics             
window.
Toolpath: Show and hide toolpath and NC paths.
Orientation: Viewing perspective for the data currently displayed in the graphics window.
Zoom: Enlarge or reduce the current view in the graphics window.
Move: Pans the current view in the graphics window.
Rotate: Rotates the current view in the graphics window.
You can assign these functions to key combinations so that they are more directly accessible              
from the keyboard. For instructions on how to assign key combinations, see section Key-             
board.
For information on the increments of the Pan and Rotate functions, see section General.
Browser: Show or hide the hyperVIEW browser.
Toolbars: Show and hide the following hyperVIEW toolbars: Standard, Machines, View &           
Measure, Status bar and Video.
Measure: Information in section View and Measure.
Capture: Create images of the graphics window, browser or the entire application. Available            
file formats: *.png, *.gif and *.bmp. 
Create *.avi-formatted videos (standard Windows file format for video content). Specify the           
video capture settings on the menu under Options > Video . Define the file name and click                
Save to start the video capturing.

 Start capturing.

Stop capturing.

Information on the formats and how to configure them is provided in the documentation of              
the respective manufacturer.

Simulation
All the functions of this menu can also be controlled with keyboard shortcuts.
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Machine Setup
The menu item Machine Setup is only available after you select the Machine Setup tab in the                
hyperVIEW browser. All the functions of this menu can also be controlled with keyboard             
shortcuts.

Options

General

Toolpath
Dim inactive toolpaths in highlight mode
Use this command to control the toolpath display when in highlight mode (shortcut menu >              
Highlight mode). If this function is enabled, all unselected toolpaths are dimmed. 
You can define the colour of the dimmed toolpaths in a profile (menu: Options > Profiles >                
Colours). If this function is disabled, all unselected toolpaths are hidden.
Frame axes length: Use this command to control the length of the axes of the frame's coordi-                
nate system.
Tool vector length: Use this command to control the length of the tool vectors in 5-axis               
cycles. This is only available if the Show 5-axis tool vectors option has been enabled (see               
also the Toolpath Properties dialogue box).

Graphic view
Pixels per pan step: Use this command to control the increment when panning across             
objects in the graphics window.
Degrees per rotation step: Use this command to control the increment when rotating objects             
in the graphics window.

Temporary files 
Delete temporary files after use: Use this command to delete temporary files from the hyper-              
VIEW/tmp folder after they have been used.
Delete all temporary files now: Deletes all files located in the temporary directory. The func-              
tion is only available after hyperVIEW has been started, provided no files have been loaded.

Report

General
Show report after generation: Controls whether the file created with the Report command is             
automatically opened in the standard program after the end of the command. The option has              
no effect on reports that are generated within a postprocessor run. 
Execute report 2017 after NC generation: Controls whether, after generating an NC file (only             
on the job list level), reports should also be generated.

Add *.xsl report as template.

Remove report

If no report template is entered in the list, each time after generating the NC file the user will                  
be prompted to select the required report. But only if the template directory            
"...\reportScript\[Language]\joblist\template\..." contains more than one report template. 
Overwrite Report 2017 output folder: If the option is enabled, an existing report directory is              
deleted and a new directory is created.

Storage location
Specify where a created report is to be stored.
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Default: The report is stored in the Global Working Space or in the project folder. 
Ask: It is possible to define the storage location before saving the report.
Other: Specify another storage location for the report.

Select report storage location

Logo
Displays the logo used for the report. 

Select another logo.

Expert

Machine change
Enable query when the machine of a NC-Job changed: When this option is enabled, the pro-               
gram queries upon each machine change whether the machine is to be used as the default               
machine for all NC jobs.
When the option is disabled, use one of the following two options to specify whether the               
selected machine is to be used for all NC jobs and/or as default machine
Enable query after changing the default machine: When this option is enabled, then each             
time the default machine is changed the program queries whether all the NC jobs are to be                
sent to the default machine.
When this option is disabled, use the following option to specify whether the selected             
machine is to be the default machine for all NC jobs.

Simulation
Apply tool colours from tool colour table: As a default, you can disable the tool colours list or                 
assign it to the used tools or paths. 
Enable the Off function to configure the tool colours manually (NC Jobs tab in the hyper-               
VIEW browser).
Movements to show when partial tool path display is enabled: Specifies the length of the par-               
tial toolpath displayed in the simulation.
Consider spindle: Enable this option to display the tool head in the simulation.
Consider additional information on tool length: Value that is automatically assigned to the            
tool length (if defined, see the Tool dialogue). The simulation runs without the need for any               
manual intervention. All report files calculate this additional value and specify the tool length             
actually required.
Use hyperMILL colours: Enable to take the colours defined in hyperMILL for G1 and G0              
movements. If this function is disabled, you can define the colours on the hyperVIEW menu              
under Options> Profile > Colours.

Profiles
Profile: Select the required profile or select the <New profile> entry. Rename the new profile              
as needed. Use the profiles to define the colours and options of your mouse button functions               
and key assignments.
Colours: Select the colours required for the available options: toolpaths, surfaces and solids,            
background and simulation.
Tool Colours: Define the colours for tools.
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Colours
Here, you can specify colours for the individual tools. The specified colours are used in the               
simulation to visualise the tool, the path taken by the tool the material removed by the tool                
(cutting edge).
The individual colours are ordered numerically.

Define a new colour.

Edit the selected colour.

Delete the selected colour.

View

Left mouse button / Middle mouse button / Right mouse button / Mouse wheel
Here you can define the following functions for the graphics window: rotate, pan, zoom. You              
can assign functions to the left, centre and right mouse buttons as well as to the scroll wheel.                 
You can also assign them functions that use combinations of the SHIFT or CTRL keys.

Keyboard

Command
For all of the commands contained in the hyperVIEW menus, you can assign key combina-              
tions consisting of up to four keys.
Category: Select the category in question from the list (the categories correspond to the             
commands in the hyperVIEW menus).
Name: Select the command in question and position the mouse pointer inside the entry field.

Specify key 
New key: Press the key combination of your choice.
You can combine any of the following: Shift key, Ctrl key and Alt key with numeric or alpha-                 
numeric keys.
The following keys cannot be used for key combinations: Backspace, Return/Enter, Tab and            
Escape.

Assign: Link a key combination with a command.

Delete: Delete an assignment.

NC file

Common
Use toolpath name of first loaded tool path as default for NC file.
See the information in section Machine Properties / NC-File properties.

NC file generation
Ask for tool data modification
Before the NC file is generated, the Tool data / Stock window opens for you to modify the                 
entries.
Start NC-Editor after file generation
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After the NC file is generated, the editor assigned to the file type in question opens automat-                
ically. If several NC files are generated, the NC file selection dialogue is called up.
The function is not activated by default. 

Machine model

Rotary axes / Tool axis
You can define the display, colour and length for the machine elements rotary axes, tool axis               
and reference point for the machines that are used in the simulation.

Increments
Length and angle by which the machine axes can be moved.

Origin name scheme
In addition to the prefix and suffix, you can also include axis descriptions and values in the                
name scheme.

Print and CSV Layout
Create print layout
Select the <New layout> option and enter a name for the layout. Confirm the dialogue box               
with Yes and close it.
Define printing information
Double-click an entry in the Available values column to move the selected value to the              
Selected values column and include it in printing.

Include the selected value in the print and CSV layout.

Move the selected value to the top of the list.

Move the selected value one line up.

Move the selected value one line down.

Move the selected value to the bottom of the list.

Delete the selected value. 

Delete all the values in the list. 

Accuracy

Metric / Inch
Here, you can define the display accuracy for the following parameters: Position (of tool),             
Feed rate (of tool), Direction, Spindle speed and Simulation.

The default value defined for simulation can be overwritten in the Tool dialogue 
(shortcut menu : Toolpath).
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Video

Video Options
Video codec: You can specify the video format here. The following formats are available by              
default under Windows: Cinepak codec (Radius), Uncompress, Indeo Video 5.1.

Configuration
For further information on how to configure the individual video formats, consult 
the documentation supplied with the formats.

Quality: If the selected format supports this option, this is where you can set the display qual-                
ity.
Frame rate: Use this parameter to specify the number of frames (images) per second. High              
frame rates increase the file size and slow down simulation. Our recommended frame rate is              
5 fps; this still yields a reasonably high display quality.
Source: Specify the video source. You can choose between the following options: Applica-            
tion: the content of the entire application window is captured. Graphics window: the content             
of the graphics window is captured. Screen: the content of the screen is captured.
With mouse cursor: the mouse cursor is included in the capture.
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Functions in hyperVIEW browser
All of these functions can be accessed from the NC-Jobs, Simulation and Machine Setup             
tabs of the browsers.

NC-Jobs
Manage NC jobs. An NC job (*.hv) consists of the following elements: machine, stock,             
model, result, rest material, clamp and toolpaths.

Simulation
Simulate NC jobs. To control the simulation, set the machine origin, configure the display of              
the machine, tool and model and configure the collision check.

Machine Setup
Specify the settings for the machine model, including the active origin, machine position, the             
available workspace and the machine display. These settings are only available if the            
machine definition includes a machine model.

NC-Jobs tab
To create a new NC job, select Edit > New NC-Job on the menu bar or right-click in the                  
browser window and select New NC-Job. A new NC job entry appears in the browser along-               
side a list of all associated elements (tree structure).

The name defined in the Machine Definition or NC-File Properties dialogue is 
used as the file name of the new NC job.

Icons in the hyperVIEW browser

NC Job (postprocessor run has not yet been carried out)

NC Job (postprocessor run has been carried out and an NC file has been gen-
erated)

Machine

Part (model, result, residual stock) is defined

Part (model, result, residual stock) is not defined

Stock is defined

Stock is not defined

Clamping devices

Toolpaths

Frame system

Element is visible
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Drag-and-drop functions
You can copy and move the stock, model, result and toolpath entries of an NC job using                
drag-and-drop operations.

Exception:
The result of one NC job cannot be used as the result of another NC job.

To move an entry, select the entry and drag it the required position in the hyperVIEW               
browser while holding down the mouse button.
To copy an entry, select the entry and drag it the required position in the hyperVIEW browser                
while holding down the CTRL key.
The standard Copy and Paste commands apply to all of the entries.
To edit the NC job that has been created, select the NC job and choose the NC-File Proper-                 
ties function on the shortcut menu.
To edit a machine assigned to the NC job, select the machine and choose the Machine prop-                
erties function on the shortcut menu. 
hyperVIEW usually creates one NC job for each joblist received from hyperMILL. To com-             
bine toolpaths from different job lists into one NC file, use the Combine all function. 

Machine Properties / NC-File properties
Use the two dialogues to specify which parameters are included in the generation of NC              
files. Note that the data entered in the Machine properties dialogue is saved as part of the                
machine definition. In the Machine properties dialogue, you can define additional machine-           
specific information such as name, postprocessor or origins. When you create a new NC job,              
all of the properties of the current machine are imported. You can use the NC file properties                
dialogue to overwrite specific machine definition properties.

General
Name/Type: Enter machine designation and type.
Adaptor: Define adaptor.
Multiple solution support: Available if several solutions are possible for the rotation axes of             
the defined machine.
Postprocessor: Click this entry to show the icons for defining and configuring the postproces-             
sor.

 Select the postprocessor required for the machine. 

OPEN MIND recommends that all postprocessor files be managed in the Global Working            
Space in the hyperVIEW directory. Due to compatibility with Windows UAC, you can no             
longer manage files in the C:\ProgramData\OPEN MIND\hyperVIEW folder. 

You can also use a postprocessor in a shared network. In this case, you should 
always save the *.def file as a write-protected file in order to protect it from 
unwanted changes.

Toolpaths in highlight mode

Element is not visible
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 Configure the postprocessor.

 Show information on the machine model.

Copy information on the postprocessor to the Windows clipboard and, if neces-
sary, make it available to your OPEN MIND partner. To do this, paste the infor-
mation stored in the clipboard into an e-mail.

Select a machine model file (*.mmf/*.mmb). Machine definitions (*.mdf) are 
managed both for hyperVIEW 32-bit and hyperVIEW 64-bit in the Global Work-
ing Space of the MDF directory. 

 Configure the machine model.

 Show information on the machine model. 

Edit the machine model file (currently intended for internal OPEN MIND use 
only).

External simulation: VERICUT is available as an external simulation program.

Origins
Select the Enabled checkbox and select an origin table file (.odf) via the Origin table entry. 

Select an *.odf file. If the file is not located in the C:\Users\Public\Docu-
ments\OPEN MIND\mdf [Global Working Space] directory, the origin table file 
will be copied into this directory. 

Edit the origin table file. The origin definition in the machine administration is 
only available with the proper licence and postprocessor. 5

NC file

 Select a target folder for new NC file. 

Specify the file name and file extension for the NC file created in the postprocessor run. The                
name of the NC file is also used when a new NC job is created.
Write comments to NC-File: Select this option to adopt comments from toolpaths in the NC              
file.
If the Use POF-file name of first loaded tool path as default for NC-File option is selected on                 
the Options > NC-file menu, the name specified for an NC file in the Machine properties dia-                
logue is replaced with the name of the first loaded toolpath.
Prologue, Epilogue: Text issued at the beginning and end of the NC file which may contain               
the following variables:

Version > Version 

Version > Postprocessor version
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DNC start/DNC end: information that is not processed by the postprocessor itself, but by pro-              
grams that are invoked after the postprocessor run (for example, management tools for NC             
files). You can use the same variables as in the fields prologue and epilogue. 

Version > Postprocessor program version

Date/Time > Creation (day)

Date/Time > Creation (month)

Date/Time > Creation (year)

Date/Time > Creation (hour)

Date/Time > Creation (minute)

Date/Time > Creation (second)

Job list comments > 1, 2, 3...

Machine > Name

Machine > Type

Machine > Adaptor

Machine > Model name

Machine > Model path

Statistics > Total machining time - hours

Statistics > Total machining time - minutes 

Statistics > Total machining time - seconds

NC > Path

NC > File

NC > File name

CAD > Path

CAD > File

CAD > File name

CAD > File path

Other > NCS name

Other > NCS comment

Other > Material

Other > Fixture name

Other > User
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Job mode
One NC-file per job: Select this option if a separate NC file is to be generated for each tool-                  
path. Otherwise, all toolpath files will be written to a single NC file during the postprocessor               
run. The job name or joblist name is used here. If a separate NC file is written for each tool-                   
path, the rule for file name generation is applied when the respective NC file is generated. 
Compound job as single job: A separate NC file is generated for a compound job.
Rule for file name generation: You can enter any combination of numbers and characters.             
The pre-defined parameters for the job list name, job name, job ID and counter are also               
available.
Start of counter: The generated files are numbered consecutively, beginning with the first            
number specified (n; n+1; n+2).
Increment to job ID: Amount of incremental increase in job ID.

Numbers
First program number / First block number: For program and block numbering, you can             
specify the first number as well as the required increment (depending on which postproces-             
sor is selected).

Tool
Type of tool change: Tools can be changed manually or automatically. Tool change position:             
If the tool is changed manually, you need to enter the corresponding position here.
Go to position before first tool change: The position of the manual tool change will also be                
considered/approached for the first tool.
Time for automatic tool changing: Enter the time available for automatic tool changing.

Positions
Start of machining X/Y/Z and End of machining X/Y/Z: If required for control, enter the tool               
position at the start and end of machining.

4/5 axes
Rotation axis X, Y, Z: Centre position of rotation axis in NCS.
Clearance radius / Clearance distance: Define the clearance radius for machines with more            
than three axes. Define the clearance between the tool and the rotation axis or workpiece              
(when indexing).
Clearance height: Z position of the tool before tilting.
Axis interpolation: Specify the angle or vector (great circle).
Max. deviation (degree): Enter value.

The evaluation of this parameter is PP-specific.

Limits
Maximum rapid feedrate / Maximum machining feedrate / Maximum spindle speed / Maxi-            
mum file size / Maximum number of NC lines: If the toolpath file (*.pof) contains large values                
for the above parameters, they are automatically reduced to the maximum values specified            
here if the corresponding option is selected.

Withdraw and retract movements and machine stop are entered prior to sepa-
ration.
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Cylinder Barrel
Settings in this category are only required in the specific case of 2.5D cylinder barrel machin-               
ing. This requires a special postprocessor. 

Program halt
Enter commands in the NC file that trigger a program halt at critical points.
Under Mode, specify whether these commands should be inserted before or after a tool             
change.
Commands: Enter the commands you want to insert in the NC file.

NCS Transformation
Define a predetermined offset for the NCS. First, the rotation is executed, followed by the              
displacement. Thus, a displacement refers to the rotated NCS. A warning is issued in this              
context when loading data in hyperVIEW and during the postprocessor run.
Select the Enabled checkbox to turn the NCS transformation on. X offset moves the NCS in               
the direction of the X axis, Y offset in the direction of the Y axis, and Z offset in the direction                    
of the Z axis. A value must be entered for the required distance. Rotary axis determines the                
axis of the NCS around which the NCS is to be turned. Rotation angle defines the value for                 
the rotation. It is applied only if the rotation axis has the value x, y or z. 

Collision check
Only available in the Machine properties dialogue.
Collision check options for the simulation. Select the Enabled checkbox below the required            
option in order to enable it. Tolerance and colour can be specified for each individual option.               
All other information, such as machine, stock and so on, are taken from the first NC job in the                  
hyperVIEW browser.

Machine Administration
Use Machine Administration to create new machines or edit existing machines.

Open the Machine administration dialogue.

New: Create a new machine.

Edit: Edit a machine. Specify the parameters of your choice in the Machine 
Definition dialogue. 

Delete: Delete the selected machine.

Copy: Copy the selected machine.

Import: Import a defined machine (load a machine definitions file in *.mdf for-
mat).

Default: Define the selected machine as a default for when a new NC job is cre-
ated.

Select the machine by entering characters
When entering letters from the keyboard, a machine below the currently selected machine is             
selected that matches the letter(s) entered. In case of ‘rapid’ input, the character string is              
evaluated in context. 
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Stock
Use the shortcut menu of the Stock entry to assign a stockmodel to the NC job by defining it                  
as a cube/cylinder or importing it as a mesh in *.STL or *.VIS format. If you open the program                  
from hyperMILL, a stockmodel can also be transferred. The stock is used for the following              
purposes displaying the simulation, and calculating the results.
Machining sequence
To use the calculated stockmodel as a basis for the stockmodel of the subsequent NC job,               
copy the stockmodel to the stockmodel of the NC job using a drag-and-drop operation. Insert              
a stockmodel using the shortcut menu Insert cube / Insert cylinder / Insert mesh. Specify the               
required stock parameters in the Cubical stock model or Cylindrical stock model dialogue.

Dimensions
X, Y, Zmin /Zmax: The minimum and maximum dimensions of the cube are proposed by the               
program and can be changed as required.

Appearance
Select the view options of your choice.

Centre of bottom
X, Y, Z: A centre value is proposed by the program. You can change this as required.

Boundary Offset
Diameter, Height: Use the values or enter your own. 
Direction: Select the orientation of the stockmodel along the X, Y or Z axis.

Appearance
Select the view options of your choice.

If one or more toolpaths have already been assigned to the NC job, the meas-
urements of the stock are automatically adapted to the existing toolpaths.
If a stock (cuboid/cylinder) has already been defined in the CAM application, 
this is proposed for the simulation.
Modify the dimensions so that they match the toolpath to be simulated.

The stockmodel can be made visible or invisible, or displayed in shaded, transparent or wire-              
frame mode. The Properties shortcut menu of a defined stockmodel allows you to display             
additional properties (Number of elements) and edit others (Visibility, Colour, Mode).

Model
Use the Insert part shortcut menu to assign a model in *.3DF, *.STL or *.VIS format to the                 
NC job. If you open the program from hyperMILL, a model can also be transferred.

Result
Use the Calculate shortcut menu to calculate the resulting stock. Prerequisite: Stock and            
toolpaths have been assigned. The calculated stock is displayed in the graphics window            
under Result.

Toolpaths
Using the shortcut menu of the Toolpaths entry, you can assign toolpaths to an NC-Job and               
check and change the properties of toolpaths. To insert a toolpath, use the Insert toolpaths              
shortcut menu and open the Insert toolpath file dialogue:

File selection
set filter (*.pof/*, etc.).
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Set the drive and directory or enter the path manually and click the 
arrow to apply.

Select the path from your favourites.

Click the Insert button to copy the set path into your favourites list. 
Accept files. Select the required files in the top list displayed.

Files are copied to the lower selection list by clicking the arrow 
with the left mouse button or by double-clicking the file name. 
Import files with OK.

Remove selected entries / all entries from selection list.

 Move selected entry upwards / downwards.

To improve clarity when several toolpaths are displayed in the graphics window, the tool-             
paths can be displayed in highlight mode and/or in different colours.
The Tools... shortcut menu of the Toolpaths entry provides a list of the tools used in the NC                 
job.

If the tool does not have a unique NC number, for example, if several tools with 
different geometries use the same NC number, the respective tools are high-
lighted in red.

Various tool parameters are displayed in the list display in the dialogue. Some of these              
parameters (Accuracy, 5X comp. length) can also be edited directly. Select the desired entry             
in the list, right-click, and select Edit. 
Double-clicking an entry in the list opens a Tool dialogue box. This dialogue box displays an               
overview of all the tool's geometry and technology parameters. The most important technol-            
ogy parameters can also be edited. 
When you are done, click Close or Exit.
As well as tool parameters, the list also displays the tool/toolpath colours defined in Options              
> Profiles. If no default behaviours are defined in the Options menu, you can assign the               
defined colours to the tools or toolpaths here. 
Click the Reset button to use the default colour for all the tools. In addition to the colours                 
already defined in Options > Profiles, you can define new colours for the individual tools/tool-              
paths here.
The Coordinate systems shortcut menu lists all the coordinate systems of the current NC job              
including origin and reference system.

The report file that is generated only contains information on the selected NC 
job or toolpath. The printout lists information on all of the NC jobs contained in 
the browser.

In addition, you can list individual statistics for each toolpath, such as: length of movement in               
G0, G1, G2/G3, dwell times and the number of tool changes.
Feedrate Analysis
The feedrate values of the calculated toolpaths are displayed using different colours. This            
allows for an easier and faster check of the toolpaths and the feedrates selected or calcu-               
lated. Particularly during High Performance roughing, the realised feedrate adjustment can          
be checked and reproduced easily.
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Displayed range

Available range

Reset

Max

Min

Displayed range
Change the largest or smallest feedrate dis-
played manually or with the arrow keys. The 
colours used for each feedrate area are dis-
played in the colour scale. 
Toolpaths with only one feedrate value are 
shown in red, 
Feedrates outside the displayed range are 
shown in white. 
Select Reset to restore the original values.
Available range
Max / Min: Largest and smallest feedrate in 
the toolpath.

In 2D Contour Milling, only the centre path is displayed.

The Properties shortcut menu displays the following parameters for editing: the most impor-            
tant technology parameters: Feedrate, Infeed, Spindle speed.
The toolpaths can be displayed in an external editor as follows: In the Properties dialogue,              
right-click the respective entry next to Source file and choose Show toolpath.

Write an NC file. Select storage location.

The following parameters are displayed on the Properties shortcut menu but they cannot be             
edited: dimensions, internal number (relating to the current NC job), cycle description           
(including creation date) and display settings for the graphics window (visibility...).

Appearance
Visible: Select this option to display the toolpath that has been inserted in the graphics win-               
dow.
Show 5 axis tool vectors: Select to display the 5-axis vectors for 5-axis toolpaths. 
Display truncated toolpath: Toolpaths that have been cut off and that led to a holder collision               
(stored in the toolpaths) are displayed in the simulation. 
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Show NC path: This option is not available unless the toolpath has been created with a cycle                
that contains the Path compensation option (2D Contour Milling, 2D Contour Milling on 3D             
Model and turning cycles). The difference between the corrected and the simulated toolpaths            
is shown. 
Double-clicking the colour fields also allows the respective colours to be defined for G0 and              
G1 as well as for NC paths (G0 / G1) and local points. 

Use the Point properties function on the Measure toolbar to display local points 
in the graphics window. 

 Generate a list of the cycle parameters set.

 Open the toolpath of a job in an external editor.

NC text: Enter user-defined text blocks such as control instructions or other similar parame-             
ters in the NC text dialogue.

Insertion position / NC text
Select the corresponding position where the NC text is to be inserted. There are no limita-               
tions to the text length or the characters used (including symbols).
Copy: Copy the NC text defined to the clipboard.
Load: Open any text file. The content of the file is displayed in the NC text area.

As hyperVIEW does not perform any syntax or collision checks on the entered 
data, you should only use this function if you are certain the used machine can 
interpret the data correctly.

Simulation of compound jobs
A compound job is shown as an entry in the hyperVIEW browser (1). The following functions               
are available on the shortcut menu of the compound job:
Insert toolpaths: Load a toolpath file and add the job to the compound job.
Edit NC-File: Open and edit the generated NC file in the editor. Requirement for generating              
an NC file for a compound job: In the NC-file properties dialogue, the Job mode > Compound                
job as single job option must be selected. 
Simulation: Simulate all the jobs of the compound job.
Tools: Show all the tools of the joblist.
Statistics: Show the statistical data of all the jobs in the compound job.
All other functions in the shortcut menu correspond to the shortcut menu for an individual              
job. For more information on this, please see the previous section. 
The following functions are available on the shortcut menu of the Machine properties entry             
(2):
Job mode > One NC-file per job: Select this option if a separate NC file is to be generated for                   
each job.
Compound job as single job: Select this option to write all the jobs in a compound job to a                  
single NC file. This function can only be enabled if the One NC-file per job function is also                 
enabled. The name of the compound job is used for the <JOB> placeholder in the  NC file.
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NC-Jobs Simulation Machine Setup
Blade machining

DIN ISO
Parts
Clamping devices
Toolpaths

Blade machining
1:T1 Roughing 01
2:T1 Roughing 02
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Simulation tab
Simulate NC jobs. To control the simulation, set the machine origin, configure the display of              
the machine, tool and model and configure the collision check.

Machine origin
Select the machine origin from the list. The toolpaths and model are aligned to the origin.

State
List of all simulated jobs. Information no the tool number, tool geometry and coolant.

Open the Solutions dialogue

 Select solutions for rotary axes
Depending on the machine kinematics, there may be several approach and retract paths for             
different tools. Select the most suitable solution in the dialogue. 
The availability of a machine model is a prerequisite to calculate possible rotary axis solu-              
tions. If these solutions will also be used by a postprocessor, the machine model and the               
postprocessor must be synchronized. Please contact your OPEN MIND dealer to arrange           
this. Implementation may involve adaptating your postprocessor and this might incur a fee. 
Toolpath: Shows the job. 
Solution: All possible solutions for the selected job as calculated by hyperVIEW. If you have              
machines with serration, possibly more than two solutions are found. In this case, the num-              
ber of offered solutions depends on the defined Maximum deviation (degree) for tilting, which             
can be defined in the Machine Properties dialogue, 4/5-Axes category. 
Deviation: Real value for the tilt deviation. 

In some types of machines (such as those with parallel rotary axes), one of the 
rotary axes may need to have a fixed position. 

Enable solution
Double-click the Solutions column to enable and use a solution. The solution will be shown in               
a bold font. The selected solution is then used in the simulation, but not for NC output. To                 
also have the selected solution used for NC output, you must save the selected solution.
Save active solutions.

Save the active solutions for all jobs. These will be stored after closing the pro-
gram and remain available the next time the program is started. An exception to 
this is if the job was recalculated in hyperMILL.

 Delete the active solutions. 

After switching to the Simulation tab at least once, the stored solutions are 
shown as a tooltip for the corresponding toolpath in the hyperVIEW browser.

Application of active solutions
In the hyperVIEW menu, click Options > NC file. Select the desired option under Stored solu-               
tions and close the dialogue with OK. 
Delete stored solution
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To delete the stored solution, select a toolpath in the hyperVIEW job browser, and select the               
Delete stored solution function from the shortcut menu. The stored solution for the marked             
toolpath is deleted.
There is currently no selectable solution available for jobs containing transformations. OPEN           
MIND recommends combining jobs containing transformations into a linking job. Please note           
that to receive a solution selection, the transformations must be defined in the sub-jobs.

Display the fixed rotary axis. You can specify the corresponding angle directly 
in the box (double-click). After the angle has been entered, the available solu-
tions are recalculated.

Compare the available and used workspace.

Workspace
Limit switch: Available workspace of the machine model. 
Min / Max: Workspace used in the simulation. All displayed values refer to the defined refer-               
ence point. 
Additionally, the difference values between the used and available workspace can be           
shown.

Display the active reference point.

Violations of the available workspace. You will need a special licence to control 
the defined workspace. Please contact your OPEN MIND dealer to arrange 
this.

Machine origin
Find best fit: Looks for the machine origin that produces no workspace violation or the small-               
est possible workspace violation. 
Define best fit: This function opens the Machine Origins and Reference Points dialogue and             
displays the automatically defined Best Fit location in a blue colour. 

Insert a new origin/reference point

Edit an origin/reference point

Delete an origin/reference point

Activate an origin/reference point

Insert the origin from current machine position.
Set reference point from current machine position.

Move the machine to the selected origin/reference point
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Legal Reminder for the Usage of the Machine Tool Models and Machine Tool 
Simulation
The terms of the End-User Licence Agreement are also valid here. OPEN MIND 
does not warrant in any way situations where incorrect data and incorrect infor-
mation delivered by the licensee have lead to the creation of an incorrect 
machine tool model. Licensee shall make an incoming inspection immediately 
after the delivery of each machine tool model. 

Use selected: The currently set machine origin is used.

Copy the maximum and minimum values displayed to the clipboard.

Open the Collision check options dialogue.

Enable: List of available checking options. Enable the desired option. Only those options that             
are useful for the NC job to be simulated are available. However, all options are available               
within the Machine properties in the Collision check dialogue.

Tool against model: If this option is selected, only the non-cutting part of the 
tool will be considered in hyperVIEW. This is defined using the Cutting length 
parameter of the tool. If the Cutting length has the value 0, it will be assumed 
that the entire tool cuts.

When the collision check is enabled, all G0 traversing movements are checked against the             
model, whereby the tool and holder can be checked separately. G1 traversing movements            
are not checked against the model.
Double click an entry in the Max. increment list to specify the accuracy of the collision check.                
Note that higher levels of accuracy will slow down the simulation. 
Double-click an entry in the Colour list to define the colour used to display detected collisions               
during simulation. 

Both the elements enabled in Collision Check Options and the toolpaths will be 
highlighted in the specified colour. 

All of the options provided in this dialogue box can also be accessed via the corresponding               
right-click shortcut menu. This way, you can modify the overall definitions for the list entries.              
You can also enable/disable collision checking for all of the list entries.
Shaft allowance: During simulation, the tool shaft is increased/decreased (positive/negative         
values) by the specified shaft allowance. This helps to reveal collisions in complex situations             
where the shaft is required to have a minimum distance to the part.

Show collision status: Display collisions that were detected during the simula-
tion in a list.

Show properties of the active toolpath's tool: Display an overview of all the tool 
parameters. This dialogue is the same as the dialogue available from the Tool-
paths shortcut menu in the hyperVIEW browser.

Show properties of the active toolpath: Display the parameters of the currently 
simulated toolpath. This dialogue is the same as the dialogue available from the 
Toolpaths shortcut menu in the hyperVIEW browser.
12-28 hyperMILL



hyperVIEW 1NC-Jobs tab Functions in hyperVIEW browser   
In contrast to the dialogues available on the shortcut menu (NC-Jobs tab), the 
parameters in the two dialogues on the Simulation tab serve only to provide a 
better overview. They cannot be edited.

Controlling the simulation

Setup
Stop simulation: In some situations, the simulation can be stopped automatically. Set the            
corresponding switches to On if the simulation is to be stopped.
M0: Stop at the next halt marker.
TC: Stop at the next tool change.
Coll: Stop at the next detected collision.
LS: Stop at the limit switch.
Use Continuous to simulate the tool movements continuously; this is done in Step Mode in              
single steps corresponding to the toolpath.
Override: Please use the scroll bar to control the simulation speed. In continuous mode, you              
can freely control the speed. In step mode, you cannot select a value below 1x. 

Override
Use the slide control to set the speed of the simulation.

Animation control
Control the simulation.

Go back to first toolpath

Previous toolpath

Fast backward

Backward

Stop

Forward

Fast forward

Forward to movement no.

Next toolpath

Go to end of last toolpath
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Mode
Configure the display for material (removal), model, machine, tool and toolpath. 

Material removal simulation disabled. Open the Create stock dialogue. Define 
the shape and display for the stock.

Material removal simulation enabled (only if a stockmodel has been defined).

Material removal shaded

Material removal transparent

Material removal wireframe

Save the result of the material removal simulation in the*.stl, *.vis or *.omg for-
mat.

Model shaded.

Model transparent.

Model wireframe.

Model invisible.

Automatic collision checking disabled.

Automatic collision checking enabled.

Enable collision checking to include the activated checks. A reverse simulation 
is not possible.

Open the Machine structure dialogue.

Machine component visible.

Machine component invisible.

Show all machine components.

Hide all machine components.

Tool shaded

Tool transparent

Tool as wireframe

Tool invisible
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Clears all conflicts: All of the conflicts displayed in the simulation (collisions and workspace             
violations) are deleted. This applies to the toolpaths as well as to all other visible elements in                
the simulation (model, machine, etc.).
Collisions Visible: Select this option to display the affected parts (machine, model, and so             
on) in the defined colour.
Clears collisions: All of the collisions displayed in the simulation are deleted.
Linear Axes Conflicts Visible: Violations of the maximum permissible workspace are dis-           
played in the defined colour. 
Clears linear axes conflicts: All of the displayed conflicts (see above) are deleted from the              
simulation.
Rotary Axes Conflicts Visible: Positions where the values of the machine's rotary axes are             
not permitted are displayed in the defined colour.
Example: a rotary axis may only move between +90° and -90°.
Clears rotary axes conflicts: All of the displayed conflicts are deleted from the simulation.

Open the Machine structure dialogue.

Part: Display components available for the machine model.
Colour: Define the colour for the machine component. Double-click the component line, then            
click the triangle icon to open the colour selection dialogue and select the required colour. 
Display: Define the display option for the machine component. Double-click the component           
line, then click the line to show the available options (Shaded, Transparent, Wireframe) and             
select one. Use the machine component shortcut menu (right-click) to unify the visibility, dis-             
play and colour for all components. Alternatively, control the visibility using the Show all and              
Hide all buttons. 

 Open the Simulation info dialogue.

The following parameters are displayed:

General
Movement no. / all, movement type, machining time.
You can also obtain this information and the tool change times from the Statistics shortcut              
menu of the Toolpaths entry on the hyperVIEW browser > NC-Jobs tab.

Position
The current position of the tool (X, Y, Z), the workspaces defined for each direction as well                
as workspace violations.

Rotary axes
The movements of the Rotation axes (if available on the respective machine model) and             
their workspaces.

Display all toolpaths.

Only display the current toolpath.

Only display the current tool movement.

Do not display any toolpaths.
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Tool vector
For turning cycles, display is extended by adding the turning-specific tool vector parameters            
(U, V, W), as well as the feedrate and spindle RPM.

Technology
Displaying the tool position and workspace in the Simulation Info dialogue box

(1) Maximum start and end points that were reached in the current simulation.
(2) Defined workspace.
(3) Current position of the tool.
(4) Workspace violation.
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Machine Setup tab
Specify the settings for the machine model, including the active origin, machine position, the             
available workspace and the machine display. 

Active origin
The active machine origin is the machine's NC zero point. Select the <Automatic> option to              
use the origin that is suitable for the machine model. If the automatic machine origin fails to                
function correctly, there is a fault in the machine model. In this case, please contact your               
OPEN MIND dealer.
Select the coordinate values for the machine origin from the list or

 open the Machine origins and reference points dialogue.

The machine origin is based on one of the following: the program coordinate system or the               
machine coordinate system (and a corresponding reference point).

Machine Position
Individual machine positions can be approached with full accuracy. To do this, right-click in             
the Position column for the relevant axis and select Edit or double-click in the relevant line.

 Move the respective axis of the machine model in the graphics window.

Use the shortcut menu to enter additional appearance options. To do this, right-click in the              
Position column and select Options or double-click in the relevant line.
The Machine model options dialogue opens.

Available workspace: If the workspace is not defined in the machine model, 
define the minimum and maximum values for the machine's linear axes directly 
in the input line.

Take the minimum and maximum values for the machine's linear axes from the 
current machine position.

Move the machine model to the defined position. The values defined here for 
the linear axes (X, Y, Z) are transferred to the Available and Used Workspace 
dialogue and are displayed as values for the limit switch.

Open the Rotary Position dialogue.

Tool vector
Enter the tool vector (U, V, W).

Calculate the position for the rotary axes (based on the tool vector).

Move the machine model to the defined position.

Polar angles
Define the tilt angle (B axis) and rotation angle (C axis). These options are only available for                
machines that support serration. Special codes are required for this functionality. Please           
contact your OPEN MIND partner.
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 Graphical preview of the defined angle.

Define the slope and rotation angle directly from the displayed machine model.

 Define the tool vectors and calculate the rotary axes.
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Mode

Display the stock, model and result in shaded mode

Display the stock, model and result in transparent mode

Display the stock, model and result in wireframe mode

Stock, model and result invisible

Open the Machine structure dialogue.

Toolbars

Standard

Open hyperVIEW file or hyperVIEW archive file. 

 Save file in *.hv or *.hvz format 

Create new NC job

Delete all NC jobs

Generate report file

Open message window (postprocessor)

Open the Print dialogue box

Start the online help

Write NC file

Machines

Choose a machine to use for the simulation.

Open the machine definition dialogue

Open the machine administration dialogue
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The Machines toolbar is hidden by default. To show the toolbar, select View > Toolbar >               
Machines.
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View and Measure

Top view

Front view

View from left

View from right

Back view

Bottom view

Back view from right

Back view from left

Front view from left

Front view from right

Zoom into graphics window

Zoom out of graphics window

Match graphics window magnification to the model 

One step up

One step down

One step to the left

One step to the right

X axis anti-clockwise

X axis clockwise

Y axis counterclockwise

Y axis clockwise
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Status bar
(Me) metric, (In) inch: Indicates the measurement system used. To change, click the entry in              
the status bar and select the required measurement system.

Video
(1) Start video capturing, (2) Pause video capturing, (3) Stop video capturing (4) Open the              
Video options dialogue to configure video capturing. Information in section Video.

Z-axis counterclockwise

Z-axis clockwise

Analyse the properties of a point, display point coordinates.

Analyse the properties of a movement. Show type of movement (feedrate G1, 
rapid G0), point coordinates of start and end point, length, angle in Z and XY.

Measure the distance between two points. Display the point coordinates and the 
distance.

Measure the distance between a point and a movement. Display the coordi-
nates of the selected point, the nearest start or end point and its distance.

Measure the distance between two movements. Display the coordinates of the 
start and end points and their distance.
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